summaryrefslogtreecommitdiffstats
path: root/c/src/tests/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-11-11 01:04:45 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-11-11 01:04:45 +0000
commit0a9e6a4855136247c8e1d7bde9a2bff19ab23e21 (patch)
treea6b6ec9ff7c2bd781604737e1ced9c902914eb9e /c/src/tests/configure.ac
parent2003-11-10 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-0a9e6a4855136247c8e1d7bde9a2bff19ab23e21.tar.bz2
2003-11-10 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* aclocal/canonical-target-name.m4: Remove. * aclocal/canonicalize-tools.m4: Remove. * aclocal/check-custom-bsp.m4: Remove. * aclocal/check-cxx.m4: Remove. * aclocal/check-itron.m4: Remove. * aclocal/check-multiprocessing.m4: Remove. * aclocal/check-networking.m4: Remove. * aclocal/check-posix.m4: Remove. * aclocal/check-tests.m4: Remove. * aclocal/check-tool.m4: Remove. * aclocal/config-subdirs.m4: Remove. * aclocal/enable-bare.m4: Remove. * aclocal/enable-cxx.m4: Remove. * aclocal/enable-itron.m4: Remove. * aclocal/enable-multiprocessing.m4: Remove. * aclocal/enable-networking.m4: Remove. * aclocal/enable-posix.m4: Remove. * aclocal/enable-rtemsbsp.m4: Remove. * aclocal/enable-tests.m4: Remove. * aclocal/env-rtemsbsp.m4: Remove. * aclocal/gcc-isystem.m4: Remove. * aclocal/gcc-pipe.m4: Remove. * aclocal/gcc-specs.m4: Remove. * aclocal/multilib.m4: Remove. * aclocal/path-ksh.m4: Remove. * aclocal/prog-cc.m4: Remove. * aclocal/prog-cxx.m4: Remove. * aclocal/project-root.m4: Remove. * aclocal/quoting.m4: Remove. * aclocal/rtems-cpu-subdirs.m4: Remove. * aclocal/rtems-flags.m4: Remove. * aclocal/rtems-test-no-pause.m4: Remove. * aclocal/rtems-top.m4: Remove. * aclocal/target.m4: Remove. * aclocal/tool-paths.m4: Remove. * aclocal/version.m4: Remove. * .cvsignore: Remove. * ChangeLog: Remove. * Makefile.am: Remove. * PROBLEMS: Remove. * README: Remove. * configure.ac: Remove. * automake/compile.am: Remove. * automake/host.am: Remove. * automake/leaf.am: Remove. * automake/local.am: Remove. * automake/subdirs.am: Remove.
Diffstat (limited to '')
-rw-r--r--c/src/tests/configure.ac65
1 files changed, 0 insertions, 65 deletions
diff --git a/c/src/tests/configure.ac b/c/src/tests/configure.ac
deleted file mode 100644
index 223afdba40..0000000000
--- a/c/src/tests/configure.ac
+++ /dev/null
@@ -1,65 +0,0 @@
-## Process this file with autoconf to produce a configure script.
-##
-## $Id$
-
-AC_PREREQ(2.57)
-AC_INIT([rtems-c-src-tests],[_RTEMS_VERSION],[rtems-bugs@rtems.com])
-AC_CONFIG_SRCDIR([samples])
-RTEMS_TOP(../../..)
-
-RTEMS_CANONICAL_TARGET_CPU
-
-AM_INIT_AUTOMAKE([no-define foreign 1.7.2])
-AM_MAINTAINER_MODE
-
-RTEMS_ENABLE_POSIX
-RTEMS_ENABLE_ITRON
-RTEMS_ENABLE_NETWORKING
-RTEMS_ENABLE_CXX
-RTEMS_ENABLE_BARE
-RTEMS_ENABLE_TESTS
-
-RTEMS_ENV_RTEMSBSP
-
-RTEMS_PROJECT_ROOT
-
-RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
-RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
-RTEMS_CHECK_POSIX_API(RTEMS_BSP)
-RTEMS_CHECK_ITRON_API(RTEMS_BSP)
-RTEMS_CHECK_TESTS
-
-case $enable_tests in
-yes | samples )
- AC_CONFIG_SUBDIRS(tools)
- AC_CONFIG_SUBDIRS(support)
- AC_CONFIG_SUBDIRS(samples)
- ;;
-esac
-
-if test "$enable_tests" = "yes"; then
- # do functionality tests first, then performance tests
- AC_CONFIG_SUBDIRS(libtests sptests)
- if test "$HAS_MP" = "yes"; then
- AC_CONFIG_SUBDIRS(mptests)
- fi
- if test "$HAS_POSIX_API" = "yes"; then
- AC_CONFIG_SUBDIRS(psxtests)
- fi
- if test "$HAS_ITRON_API" = "yes"; then
- AC_CONFIG_SUBDIRS(itrontests)
- fi
- # Now do performance tests
- AC_CONFIG_SUBDIRS(tmtests)
- if test "$HAS_ITRON_API" = "yes"; then
- AC_CONFIG_SUBDIRS(tmitrontests)
- fi
-fi
-
-AC_SUBST(BARE_CPU_CFLAGS)
-AC_SUBST(BARE_CPU_MODEL)
-
-# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile
-])
-AC_OUTPUT