summaryrefslogtreecommitdiffstats
path: root/c/src/support/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-03-24 09:53:09 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-03-24 09:53:09 +0000
commit434b8ea11453599809d223ca144ecd9aaa4d4c9a (patch)
tree4c73e599c868f98f02050fa856d3a0c200e00f12 /c/src/support/Makefile.am
parent2003-03-18 Till Straumann <strauman@slac.stanford.edu> (diff)
downloadrtems-434b8ea11453599809d223ca144ecd9aaa4d4c9a.tar.bz2
Merger from rtems-4-6-branch.
Diffstat (limited to '')
-rw-r--r--c/src/support/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/c/src/support/Makefile.am b/c/src/support/Makefile.am
new file mode 100644
index 0000000000..9c528fc254
--- /dev/null
+++ b/c/src/support/Makefile.am
@@ -0,0 +1,20 @@
+##
+## $Id$
+##
+
+include $(top_srcdir)/../../automake/compile.am
+include $(top_srcdir)/../../automake/lib.am
+
+AM_CPPFLAGS += -DRTEMS_BSP=\"$(RTEMS_BSP)\"
+
+C_FILES=version.c
+OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+
+LIB = $(ARCH)/libsupport.a
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+all-local: $(ARCH) $(LIB)
+
+include $(top_srcdir)/../../automake/local.am