summaryrefslogtreecommitdiffstats
path: root/c/src/optman/sapi/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-21 14:32:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-21 14:32:00 +0000
commitdb3e01084a9f489dca50ad5a834c12542fd853dc (patch)
treec8969b14b4c695dcc1cf0083ad195a7f1e5e2c2c /c/src/optman/sapi/Makefile.am
parentPatch rtems-rc-19991203-5.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-db3e01084a9f489dca50ad5a834c12542fd853dc.tar.bz2
Patch rtems-rc-19991203-6.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which fixes a nasty dependency bug in optman/Makefile.am. Those directories have been build twice before, i.e. re-running make after having built rtems before, was rebuilding the files in optman/ directories. To apply: patch -p1 < rtems-rc-19991203-6.diff ./bootstrap
Diffstat (limited to 'c/src/optman/sapi/Makefile.am')
-rw-r--r--c/src/optman/sapi/Makefile.am21
1 files changed, 8 insertions, 13 deletions
diff --git a/c/src/optman/sapi/Makefile.am b/c/src/optman/sapi/Makefile.am
index 96254065ea..c98b33860f 100644
--- a/c/src/optman/sapi/Makefile.am
+++ b/c/src/optman/sapi/Makefile.am
@@ -7,18 +7,16 @@ AUTOMAKE_OPTIONS = foreign 1.4
C_FILES = no-ext.c no-io.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-SRCS = $(C_FILES)
-OBJS = $(C_O_FILES)
-
-PGMNAME = $(C_FILES:%.c=%)
PGMS = $(C_FILES:%.c=$(ARCH)/%.rel)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(RTEMS_ROOT)/make/leaf.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+TMPINSTALL_FILES += \
+$(C_FILES:%.c=$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel)
-TMPINSTALL_FILES = \
-$(PROJECT_RELEASE)/lib \
-$(PGMNAME:%=$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel)
+$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel: $(ARCH)/%.rel
+ $(INSTALL_DATA) $< $@
#
# (OPTIONAL) Add local stuff here using +=
@@ -27,12 +25,9 @@ $(PGMNAME:%=$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel)
AM_CFLAGS += $(CFLAGS_OS_V)
ASM4FLAGS += -I $(PROJECT_INCLUDE)/rtems
-$(PROJECT_RELEASE)/lib:
- $(mkinstalldirs) $@
-$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel: $(ARCH)/%.rel
- $(INSTALL_DATA) $< $@
+all-local: ${ARCH} $(PGMS) $(TMPINSTALL_FILES)
-all: ${ARCH} $(PGMS) $(TMPINSTALL_FILES)
+.PRECIOUS: $(PGMS)
EXTRA_DIST = $(C_FILES)