summaryrefslogtreecommitdiffstats
path: root/c/src/optman/rtems/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 13:29:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 13:29:04 +0000
commitfba12eb6ff4a91fcbac1c43dd3196114cc12756b (patch)
tree34477c9b77ceab1ee81e0ea4a9ee9a6e3a3975cf /c/src/optman/rtems/Makefile.am
parentAdded projects chapter to FAQ. (diff)
downloadrtems-fba12eb6ff4a91fcbac1c43dd3196114cc12756b.tar.bz2
Patch rtems-rc-19991117-11.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
to convert the libc directory to automake and "dozens of small fixes for Makefile.ins/configure.ins below c/src/lib."
Diffstat (limited to 'c/src/optman/rtems/Makefile.am')
-rw-r--r--c/src/optman/rtems/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/c/src/optman/rtems/Makefile.am b/c/src/optman/rtems/Makefile.am
new file mode 100644
index 0000000000..163bd86c97
--- /dev/null
+++ b/c/src/optman/rtems/Makefile.am
@@ -0,0 +1,40 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+C_FILES = no-dpmem.c no-event.c no-msg.c no-mp.c no-part.c no-region.c \
+ no-rtmon.c no-sem.c no-signal.c no-timer.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+SRCS = $(C_FILES)
+OBJS = $(C_O_FILES)
+
+PGMS = $(C_FILES:%.c=$(ARCH)/%.rel)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+TMPINSTALL_FILES = \
+$(PROJECT_RELEASE)/lib \
+$(C_FILES:%.c=$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel)
+
+$(PROJECT_RELEASE)/lib:
+ @$(mkinstalldirs) $@
+
+$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel: $(ARCH)/%.rel
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+AM_CFLAGS += $(CFLAGS_OS_V)
+ASM4FLAGS += -I$(PROJECT_INCLUDE)/rtems
+
+all: ${ARCH} $(TMPINSTALL_FILES)
+
+EXTRA_DIST = $(C_FILES)
+
+include $(top_srcdir)/../../../automake/local.am