summaryrefslogtreecommitdiffstats
path: root/c/src/optman/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-11-20 14:21:25 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-11-20 14:21:25 +0000
commitcccb7e04b02e7b81d214f846b31c81ab3f76c058 (patch)
treebc1dd553e7b8dec29fd4b08f952d763d3b802a69 /c/src/optman/Makefile.am
parent2002-11-20 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-cccb7e04b02e7b81d214f846b31c81ab3f76c058.tar.bz2
2002-11-20 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in rtems/Makefile.am and sapi/Makefile.am. * sapi/Makefile.am: Removed. * rtems/Makefile.am: Removed. * rel.am: Removed. * configure.ac: Add RTEMS_BSP_CHECK_CACHE. Reflect changes above.
Diffstat (limited to 'c/src/optman/Makefile.am')
-rw-r--r--c/src/optman/Makefile.am43
1 files changed, 41 insertions, 2 deletions
diff --git a/c/src/optman/Makefile.am b/c/src/optman/Makefile.am
index 4758d16a75..ee2872875b 100644
--- a/c/src/optman/Makefile.am
+++ b/c/src/optman/Makefile.am
@@ -4,7 +4,46 @@
ACLOCAL_AMFLAGS = -I ../../../aclocal
-SUBDIRS = rtems sapi
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+C_FILES = sapi/no-ext.c sapi/no-io.c
+C_O_FILES = $(C_FILES:sapi/%.c=$(ARCH)/%.$(OBJEXT))
+
+C_FILES += rtems/no-dpmem.c rtems/no-event.c rtems/no-msg.c rtems/no-mp.c \
+ rtems/no-part.c rtems/no-region.c \
+ rtems/no-rtmon.c rtems/no-sem.c rtems/no-signal.c rtems/no-timer.c
+C_O_FILES += $(C_FILES:rtems/%.c=${ARCH}/%.$(OBJEXT))
+
+PGMS = $(C_FILES:rtems/%.c=$(ARCH)/%$(LIB_VARIANT).rel)
+PGMS += $(C_FILES:sapi/%.c=$(ARCH)/%$(LIB_VARIANT).rel)
+
+${ARCH}/%.o: sapi/%.c
+ test -d $(ARCH) || mkdir $(ARCH)
+ ${COMPILE} -o $@ -c $<
+
+${ARCH}/%.o: rtems/%.c
+ test -d $(ARCH) || mkdir $(ARCH)
+ ${COMPILE} -o $@ -c $<
+
+# Make foo.rel from foo.o
+${ARCH}/%$(LIB_VARIANT).rel: ${ARCH}/%.o
+ test -d $(ARCH) || mkdir $(ARCH)
+ ${make-rel}
+
+bsplib_DATA = $(PGMS)
+
+TMPINSTALL_FILES += \
+ $(PGMS:${ARCH}/%$(LIB_VARIANT).rel=$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel)
+
+$(PROJECT_RELEASE)/lib/%$(LIB_VARIANT).rel: $(ARCH)/%$(LIB_VARIANT).rel
+ $(INSTALL_DATA) $< $@
+
+all-local: ${ARCH} $(PGMS) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(PGMS) $(C_O_FILES)
+
+EXTRA_DIST = $(C_FILES)
-include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am