summaryrefslogtreecommitdiffstats
path: root/c/src/optman/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 16:04:17 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 16:04:17 +0000
commit375e890cf306e17a775b39eb5d876d92619f55b3 (patch)
treeee3c49e10619cb5ce2880305a993275870ac55ec /c/src/optman/Makefile.am
parent2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-375e890cf306e17a775b39eb5d876d92619f55b3.tar.bz2
2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Use mkdir_p. Remove dirs from PRE/TMPINSTALL_FILES.
Diffstat (limited to 'c/src/optman/Makefile.am')
-rw-r--r--c/src/optman/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/optman/Makefile.am b/c/src/optman/Makefile.am
index fc3a882166..a663899f0d 100644
--- a/c/src/optman/Makefile.am
+++ b/c/src/optman/Makefile.am
@@ -40,6 +40,10 @@ all-local: $(PGMS) $(TMPINSTALL_FILES)
EXTRA_DIST = $(rtems_C_FILES) $(sapi_C_FILES)
+${PROJECT_RELEASE}/lib/$(dirstamp):
+ @$(mkdir_p) ${PROJECT_RELEASE}/lib
+ @: > ${PROJECT_RELEASE}/lib/$(dirstamp)
+
${PROJECT_RELEASE}/lib/no-ext$(LIB_VARIANT).rel: $(ARCH)/no-ext$(LIB_VARIANT).rel ${PROJECT_RELEASE}/lib/$(dirstamp)
$(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/no-ext$(LIB_VARIANT).rel
TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/no-ext$(LIB_VARIANT).rel