summaryrefslogtreecommitdiffstats
path: root/c/src/make/custom/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
commit1896a650fc382d343844b56f4b79efe31562755e (patch)
tree922de4dd1237cfcf6c7be0a8050e1e964fceadad /c/src/make/custom/Makefile.am
parentFixed typos. (diff)
downloadrtems-1896a650fc382d343844b56f4b79efe31562755e.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>:
The main topic is replacing the hard-coded values for HAS_MP and HAS_RDBG in custom/*.cfg with per-bsp configuration-time autoconf checks (This is the patch I had mentioned before earlier this week). CHANGES * HAS_MP removed from custom/*.cfg, replaced with configuration time autoconf check * HAS_RDBG removed from custom/*.cfg, replaced with configuration-time autoconf check * NEW: c/src/make/bsp.cfg.in, takes configuration-time checked per-bsp values (i.e. HAS_MP, HAS_RDBG), gets installed as $(prefix)/<bsp>/make/bsp.cfg * NEW: default.cfg includes bsp.cfg - this change is backward compatible. * IMPORT_SRC: apply VPATH instead for ts_386ex/i386ex subdirectory Makefile.ins * HACK: a bug in acpolish mis-handles addtions to makefile variables which are enclosed in gmake conditionals: c/src/lib/libbsp/m68k/ods68302/start302/Makefile.in * Apply inline_dir, HAS_MP and HAS_RDBG for avoiding configuration of unneeded subdirectories in various configure.in files. * Several minor changes in Makefile.ins and configure.ins, wrt. to the order of including *.cfg and defining Makefile variables APPLYING THE PATCH: patch -p1 < rtems-rc-19990709-4.diff ./autogen
Diffstat (limited to '')
-rw-r--r--c/src/make/custom/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/c/src/make/custom/Makefile.am b/c/src/make/custom/Makefile.am
index 3313913c03..5cd10d1d8b 100644
--- a/c/src/make/custom/Makefile.am
+++ b/c/src/make/custom/Makefile.am
@@ -13,7 +13,9 @@ default.cfg
if MAINTAINER_MODE
$(srcdir)/default.cfg.in: $(top_srcdir)/@RTEMS_TOPdir@/make/custom/default.cfg
- sed -e 's%\$$(RTEMS_BSP)%\@RTEMS_BSP\@%g' < $< >$@
+ sed -e 's%\$$(RTEMS_BSP)%\@RTEMS_BSP\@%g' \
+ -e 's%\$$(RTEMS_ROOT)/\@RTEMS_BSP\@%$$(RTEMS_ROOT)%g' \
+ < $< >$@
endif
include $(top_srcdir)/../../../automake/local.am