summaryrefslogtreecommitdiffstats
path: root/c/src/make/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-01 23:11:05 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-01 23:11:05 +0000
commit4619da90eb98451bea69ac5615407472f95af0ff (patch)
tree22cffc090269cd6b8d0724347d5a0b2edfc30b5b /c/src/make/configure.ac
parent2002-05-01 Eric Norum <eric.norum@usask.ca> (diff)
downloadrtems-4619da90eb98451bea69ac5615407472f95af0ff.tar.bz2
2002-04-24 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* custom/Makefile.am: Remove. * compilers/Makefile.am: Remove. * compilers/.cvsignore: Remove. * Makefile.am: Merge-in former */Makefile.ams. Add more vars to <BSP>.cache. * configure.ac: Reflect changes above. Cosmetic fixes.
Diffstat (limited to 'c/src/make/configure.ac')
-rw-r--r--c/src/make/configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/c/src/make/configure.ac b/c/src/make/configure.ac
index b566f67684..da7553c29f 100644
--- a/c/src/make/configure.ac
+++ b/c/src/make/configure.ac
@@ -92,7 +92,7 @@ f="${RTEMS_BSP}.cfg"
while test -n "$f"; do
if test -r "${srcdir}/${cfg_dir}/custom/$f"; then
AC_CONFIG_LINKS([custom/$f:${cfg_dir}/custom/$f])
- CUSTOM_CFG_FILES="$CUSTOM_CFG_FILES $f"
+ CUSTOM_CFG_FILES="$CUSTOM_CFG_FILES custom/$f"
f=`grep "^include.*make/custom" ${srcdir}/${cfg_dir}/custom/$f \
| sed \
-e 's%^.*custom\/%%' \
@@ -118,7 +118,6 @@ AC_CONFIG_LINKS([
],,[
RTEMS_TOPdir=${RTEMS_TOPdir}
cfg_dir=${cfg_dir}
- test -d Templates || mkdir Templates
])
# Explicitly list all Makefiles here
@@ -126,10 +125,14 @@ AC_CONFIG_FILES([Makefile
Makefile.inc
host.cfg
bsp.cfg
-custom/Makefile
custom/default.cfg
-compilers/Makefile])
-AC_CONFIG_COMMANDS([default],[[${MAKE} $RTEMS_BSP.cache]],[[MAKE=${MAKE-make}
-RTEMS_BSP=${RTEMS_BSP}
+])
+
+AC_CONFIG_COMMANDS([default],
+[[${MAKE} $RTEMS_BSP.cache
+]],
+[[MAKE=${MAKE-make}
+ RTEMS_BSP=${RTEMS_BSP}
]])
+
AC_OUTPUT