summaryrefslogtreecommitdiffstats
path: root/c/src/make/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-08-09 04:41:52 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-08-09 04:41:52 +0000
commit3ba1627b39463bf3aded8c719543c76f9eaa4e64 (patch)
tree1d9fbc3db5be60d2fca9d7ce4ffb0d3eb6ba5f19 /c/src/make/configure.ac
parent2002-08-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-3ba1627b39463bf3aded8c719543c76f9eaa4e64.tar.bz2
2002-08-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Remove RTEMS_BSP.cache generation. Remove handling custom/*.cfgs. Remove handling custom/default.cfg. * configure.ac: Remove handling of custom/*.cfgs. Remove auto* generated custom/default.cfg.
Diffstat (limited to '')
-rw-r--r--c/src/make/configure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/c/src/make/configure.ac b/c/src/make/configure.ac
index da7553c29f..549f111ab6 100644
--- a/c/src/make/configure.ac
+++ b/c/src/make/configure.ac
@@ -85,22 +85,7 @@ AC_SUBST(CC_CFLAGS_DEBUG_V)
AC_SUBST(CC_CFLAGS_PROFILE_V)
AC_SUBST(CC_LDFLAGS_PROFILE_V)
-# Collect the files needed to build a BSP
cfg_dir="${RTEMS_TOPdir}/make"
-CUSTOM_CFG_FILES=""
-f="${RTEMS_BSP}.cfg"
-while test -n "$f"; do
- if test -r "${srcdir}/${cfg_dir}/custom/$f"; then
- AC_CONFIG_LINKS([custom/$f:${cfg_dir}/custom/$f])
- CUSTOM_CFG_FILES="$CUSTOM_CFG_FILES custom/$f"
- f=`grep "^include.*make/custom" ${srcdir}/${cfg_dir}/custom/$f \
- | sed \
- -e 's%^.*custom\/%%' \
- -e s%\$\(RTEMS_HOST\)%${RTEMS_HOST}% \
- -e 's%default\.cfg%%'`;
- else break; fi;
-done
-AC_SUBST(CUSTOM_CFG_FILES)
AC_SUBST(cfg_dir)
# Symlink the *.cfg files from the toplevel make directory into the build
@@ -125,14 +110,6 @@ AC_CONFIG_FILES([Makefile
Makefile.inc
host.cfg
bsp.cfg
-custom/default.cfg
])
-AC_CONFIG_COMMANDS([default],
-[[${MAKE} $RTEMS_BSP.cache
-]],
-[[MAKE=${MAKE-make}
- RTEMS_BSP=${RTEMS_BSP}
-]])
-
AC_OUTPUT