summaryrefslogtreecommitdiffstats
path: root/c/src/make/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2011-03-07 04:05:18 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2011-03-07 04:05:18 +0000
commit48588ab33dabfdab85d3d8e4a80b42fcec4f8a0a (patch)
tree6e22b71f16d9e19b7cb348b93db5ae42a886c4f6 /c/src/make/Makefile.am
parent2011-03-07 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-48588ab33dabfdab85d3d8e4a80b42fcec4f8a0a.tar.bz2
2011-03-07 Ralf Corsépius <ralf.corsepius@rtems.org>
* Makefile.am, configure.ac: Move file generation into Makefile.
Diffstat (limited to '')
-rw-r--r--c/src/make/Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/c/src/make/Makefile.am b/c/src/make/Makefile.am
index 875f1b190d..3349d5cf99 100644
--- a/c/src/make/Makefile.am
+++ b/c/src/make/Makefile.am
@@ -4,6 +4,8 @@
ACLOCAL_AMFLAGS = -I aclocal -I ../aclocal
+CLEANFILES =
+
rtems_makedir = $(pkgdatadir)/make
GENERIC_FILES = host.cfg
@@ -27,6 +29,67 @@ $(srcdir)/host.cfg.in: $(top_srcdir)/@RTEMS_TOPdir@/make/host.cfg.in
cp $< $@
endif
+bsp.cfg: bsp.cfg.in Makefile
+ sed \
+ -e "s,[@]HAS_MP[@],$(HAS_MP)," \
+ -e "s,[@]HAS_POSIX_API[@],$(HAS_POSIX_API)," \
+ -e "s,[@]HAS_CPLUSPLUS[@],$(HAS_CPLUSPLUS)," \
+ -e "s,[@]HAS_NETWORKING[@],$(HAS_NETWORKING)," \
+ < $(srcdir)/bsp.cfg.in > bsp.cfg
+CLEANFILES += bsp.cfg
+
+target.cfg: target.cfg.in Makefile
+ sed \
+ -e "s,[@]CPPFLAGS[@],$(CPPFLAGS)," \
+ -e "s,[@]CFLAGS[@],$(CFLAGS)," \
+ -e "s,[@]LIBS[@],$(LIBS)," \
+ -e "s,[@]CC[@],$(CC)," \
+ -e "s,[@]CXX[@],$(CXX)," \
+ -e "s,[@]AS[@],$(AS)," \
+ -e "s,[@]AR[@],$(AR)," \
+ -e "s,[@]NM[@],$(NM)," \
+ -e "s,[@]LD[@],$(LD)," \
+ -e "s,[@]SIZE[@],$(SIZE)," \
+ -e "s,[@]STRIP[@],$(STRIP)," \
+ -e "s,[@]RANLIB[@],$(RANLIB)," \
+ -e "s,[@]OBJCOPY[@],$(OBJCOPY)," \
+ -e "s,[@]RTEMS_CPU[@],$(RTEMS_CPU)," \
+ -e "s,[@]RTEMS_HAS_MULTIPROCESSING[@],$(HAS_MP)," \
+ -e "s,[@]RTEMS_HAS_POSIX_API[@],$(HAS_POSIX_API)," \
+ -e "s,[@]RTEMS_HAS_CPLUSPLUS[@],$(HAS_CPLUSPLUS)," \
+ -e "s,[@]RTEMS_HAS_NETWORKING[@],$(HAS_NETWORKING)," \
+ < $(srcdir)/target.cfg.in > target.cfg
+CLEANFILES += target.cfg
+
+host.cfg: host.cfg.in Makefile
+ sed \
+ -e "s,[@]CP[@],$(CP)," \
+ -e "s,[@]MV[@],$(MV)," \
+ -e "s,[@]LN[@],$(LN)," \
+ -e "s,[@]SHELL[@],$(SHELL)," \
+ -e "s,[@]KSH[@],$(KSH)," \
+ < $(srcdir)/host.cfg.in > host.cfg
+CLEANFILES += host.cfg
+
+Makefile.inc: Makefile.inc.in Makefile
+ sed \
+ -e "s,[@]prefix[@],$(prefix)," \
+ -e "s,[@]exec_prefix[@],$(exec_prefix)," \
+ -e "s,[@]pkgdatadir[@],$(pkgdatadir)," \
+ -e "s,[@]RTEMS_BSP[@],$(RTEMS_BSP)," \
+ -e "s,[@]CC[@],$(CC)," \
+ -e "s,[@]CXX[@],$(CXX)," \
+ -e "s,[@]AS[@],$(AS)," \
+ -e "s,[@]AR[@],$(AR)," \
+ -e "s,[@]NM[@],$(NM)," \
+ -e "s,[@]LD[@],$(LD)," \
+ -e "s,[@]SIZE[@],$(SIZE)," \
+ -e "s,[@]OBJCOPY[@],$(OBJCOPY)," \
+ -e "s,[@]RTEMS_HAS_POSIX_API[@],$(HAS_POSIX_API)," \
+ -e "s,[@]RTEMS_HAS_CPLUSPLUS[@],$(HAS_CPLUSPLUS)," \
+ < $(srcdir)/Makefile.inc.in > Makefile.inc
+CLEANFILES += Makefile.inc
+
## At the moment all actively supported configurations
## use gcc-target-default.cfg only.
rtems_make_compilersdir = $(rtems_makedir)/compilers