summaryrefslogtreecommitdiffstats
path: root/c/src/make/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
commit1896a650fc382d343844b56f4b79efe31562755e (patch)
tree922de4dd1237cfcf6c7be0a8050e1e964fceadad /c/src/make/Makefile.am
parentFixed typos. (diff)
downloadrtems-1896a650fc382d343844b56f4b79efe31562755e.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>:
The main topic is replacing the hard-coded values for HAS_MP and HAS_RDBG in custom/*.cfg with per-bsp configuration-time autoconf checks (This is the patch I had mentioned before earlier this week). CHANGES * HAS_MP removed from custom/*.cfg, replaced with configuration time autoconf check * HAS_RDBG removed from custom/*.cfg, replaced with configuration-time autoconf check * NEW: c/src/make/bsp.cfg.in, takes configuration-time checked per-bsp values (i.e. HAS_MP, HAS_RDBG), gets installed as $(prefix)/<bsp>/make/bsp.cfg * NEW: default.cfg includes bsp.cfg - this change is backward compatible. * IMPORT_SRC: apply VPATH instead for ts_386ex/i386ex subdirectory Makefile.ins * HACK: a bug in acpolish mis-handles addtions to makefile variables which are enclosed in gmake conditionals: c/src/lib/libbsp/m68k/ods68302/start302/Makefile.in * Apply inline_dir, HAS_MP and HAS_RDBG for avoiding configuration of unneeded subdirectories in various configure.in files. * Several minor changes in Makefile.ins and configure.ins, wrt. to the order of including *.cfg and defining Makefile variables APPLYING THE PATCH: patch -p1 < rtems-rc-19990709-4.diff ./autogen
Diffstat (limited to 'c/src/make/Makefile.am')
-rw-r--r--c/src/make/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/make/Makefile.am b/c/src/make/Makefile.am
index dfc6f5cdde..29ec3234bc 100644
--- a/c/src/make/Makefile.am
+++ b/c/src/make/Makefile.am
@@ -26,6 +26,10 @@ rtems_bspdir = $(rtemsdir)/@RTEMS_BSP@
rtems_bsp_DATA = \
Makefile.inc
+rtems_bsp_makedir = $(rtems_bspdir)/make
+rtems_bsp_make_DATA = \
+bsp.cfg
+
if MAINTAINER_MODE
$(srcdir)/main.cfg.in: $(top_srcdir)/@RTEMS_TOPdir@/make/main.cfg
sed -e 's%\$$(RTEMS_BSP)%\@RTEMS_BSP\@%g' < $< >$@