summaryrefslogtreecommitdiffstats
path: root/c/src/librtems++/src/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-07-22 06:14:20 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-07-22 06:14:20 +0000
commit85107726ef303716f3e336f1ceb4f85fe75dd190 (patch)
treef408587394d5c0f7d14c3cfd8cddf820f4809ee5 /c/src/librtems++/src/Makefile.am
parent2002-07-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-85107726ef303716f3e336f1ceb4f85fe75dd190.tar.bz2
2002-07-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* src/Makefile.am: Add bsplib_DATA. Eliminate LIBNAME. Cosmetical changes.
Diffstat (limited to 'c/src/librtems++/src/Makefile.am')
-rw-r--r--c/src/librtems++/src/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/c/src/librtems++/src/Makefile.am b/c/src/librtems++/src/Makefile.am
index ace76eb21b..80829c3aa6 100644
--- a/c/src/librtems++/src/Makefile.am
+++ b/c/src/librtems++/src/Makefile.am
@@ -2,9 +2,11 @@
## $Id$
##
+LIB = ${ARCH}/librtems++.a
-LIBNAME = librtems++
-LIB = ${ARCH}/${LIBNAME}.a
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
CC_FILES = rtemsEvent.cc rtemsInterrupt.cc rtemsMessageQueue.cc \
rtemsSemaphore.cc rtemsStatusCode.cc rtemsTask.cc rtemsTimer.cc
@@ -13,18 +15,16 @@ CC_O_FILES = $(CC_FILES:%.cc=${ARCH}/%.o)
SRCS = $(CC_FILES)
OBJS = $(CC_O_FILES)
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
AM_CFLAGS += $(LIBC_DEFINES)
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/librtems++$(LIB_VARIANT).a
+
+bsplib_DATA = $(LIB)
-$(LIB): ${OBJS}
+$(LIB): $(OBJS)
$(make-library)
-$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
+$(PROJECT_RELEASE)/lib/librtems++$(LIB_VARIANT).a: $(LIB)
$(INSTALL_DATA) $< $@
all-local: ${ARCH} $(PREINSTALL_FILES) $(TMPINSTALL_FILES)