summaryrefslogtreecommitdiffstats
path: root/c/src/librtems++/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 18:51:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 18:51:47 +0000
commit8917506d1c1f80a5b157b4e137fc8dd0a3ba2319 (patch)
tree25384c442ba04bb9ee2d21528e512d40e99f596e /c/src/librtems++/include/Makefile.am
parent2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-8917506d1c1f80a5b157b4e137fc8dd0a3ba2319.tar.bz2
2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/rtems++/Makefile.am: Remove. * include/Makefile.am: Handle subdirs, require automake-1.5. * configure.ac: Reflect changes above. * Makefile.am: Require automake-1.5.
Diffstat (limited to '')
-rw-r--r--c/src/librtems++/include/Makefile.am24
1 files changed, 21 insertions, 3 deletions
diff --git a/c/src/librtems++/include/Makefile.am b/c/src/librtems++/include/Makefile.am
index 540e68ec55..1230c5b701 100644
--- a/c/src/librtems++/include/Makefile.am
+++ b/c/src/librtems++/include/Makefile.am
@@ -2,9 +2,27 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
-SUBDIRS = rtems++
+include_rtems__dir = $(includedir)/rtems++
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/rtems++:
+ @$(mkinstalldirs) $@
+
+if HAS_CXX
+include_rtems___HEADERS = rtems++/rtemsEvent.h \
+ rtems++/rtemsInterrupt.h rtems++/rtemsMessageQueue.h rtems++/rtemsSemaphore.h \
+ rtems++/rtemsStatusCode.h rtems++/rtemsTask.h rtems++/rtemsTaskMode.h \
+ rtems++/rtemsTimer.h
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems++ \
+ $(include_rtems___HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+endif
+
+all-local: $(PREINSTALL_FILES)
-include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am