summaryrefslogtreecommitdiffstats
path: root/c/src/librpc/src/rpc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-31 16:39:06 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-31 16:39:06 +0000
commit57cfaad2f5cb97a66c3353cf11f62c39dd0b5ea9 (patch)
tree4cd6e89ca949ddcda7c0438f4860abfefca8bc7a /c/src/librpc/src/rpc/Makefile.am
parent2000-10-30 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-57cfaad2f5cb97a66c3353cf11f62c39dd0b5ea9.tar.bz2
2000-10-30 Joel Sherrill <joel@OARcorp.com>
* POSIX include files merged into newlib. This resulted in some definitions moving to other files and thus some secondary effects in RTEMS source code. * src/rpc/Makefile.am, src/rpc/auth_time.c, src/rpc/clnt_simple.c, src/rpc/clnt_tcp.c, src/rpc/clnt_udp.c, src/rpc/clnt_unix.c, src/rpc/get_myaddress.c, src/rpc/pmap_clnt.c, src/rpc/pmap_getmaps.c, src/rpc/pmap_getport.c, src/rpc/pmap_rmt.c, src/rpc/rtime.c, src/rpc/svc_tcp.c, src/rpc/svc_udp.c, src/rpc/svc_unix.c: Use of _read, _write, and _close as macros conflicted with newlib's use of these as routine names. They were renamed to include "_RPC_" prefix.
Diffstat (limited to 'c/src/librpc/src/rpc/Makefile.am')
-rw-r--r--c/src/librpc/src/rpc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/src/librpc/src/rpc/Makefile.am b/c/src/librpc/src/rpc/Makefile.am
index 2d2dc10a6a..f727bafc77 100644
--- a/c/src/librpc/src/rpc/Makefile.am
+++ b/c/src/librpc/src/rpc/Makefile.am
@@ -34,7 +34,7 @@ TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
# Add local stuff here using +=
#
-AM_CPPFLAGS += '-D__P(x)=x' -D_read=read -D_write=write -D_close=close -D_RTEMS_RPC_INTERNAL_
+AM_CPPFLAGS += '-D__P(x)=x' -D_RPC_read=read -D_RPC_write=write -D_RPC_close=close -D_RTEMS_RPC_INTERNAL_
$(LIB): $(OBJS)
$(make-library)