summaryrefslogtreecommitdiffstats
path: root/c/src/librpc/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-26 19:28:11 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-26 19:28:11 +0000
commitca7858bb8856f1afcc537f39763b7c951e5068d3 (patch)
tree3f01b3bb41ce9b2d7bc16c300391382918758caf /c/src/librpc/configure.in
parentPort of RTEMS to the Texas Instruments C3x/C4x DSP families including (diff)
downloadrtems-ca7858bb8856f1afcc537f39763b7c951e5068d3.tar.bz2
Port of RTEMS to the Texas Instruments C3x/C4x DSP families including
a BSP (c4xsim) supporting the simulator included with gdb. This port was done by Joel Sherrill and Jennifer Averett of OAR Corporation. Also included with this port is a space/time optimization to eliminate FP context switch management on CPUs without hardware or software FP. An issue with this port was that sizeof(unsigned32) = sizeof(unsigned8) on this CPU. This required addressing alignment checks and assumptions as well as fixing code that assumed sizeof(unsigned32) == 4.
Diffstat (limited to '')
-rw-r--r--c/src/librpc/configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/c/src/librpc/configure.in b/c/src/librpc/configure.in
index 5edbe4076a..9d35281f0e 100644
--- a/c/src/librpc/configure.in
+++ b/c/src/librpc/configure.in
@@ -26,6 +26,7 @@ RTEMS_CANONICALIZE_TOOLS
RTEMS_CHECK_NETWORKING(RTEMS_BSP)
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+AM_CONDITIONAL(rpc_not_supported, test "$RTEMS_CPU" = "c4x")
RTEMS_PROJECT_ROOT