summaryrefslogtreecommitdiffstats
path: root/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-07-25 14:42:01 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-07-25 14:42:01 +0000
commite37d7196530443eb40fc9b269b5b19cacc3738ac (patch)
tree35f2683b304a9b81c34178fdfacbb221a26fd445 /c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
parent2003-07-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e37d7196530443eb40fc9b269b5b19cacc3738ac.tar.bz2
2003-07-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Remove (Merged into ../configure.ac). * Makefile.am, include/Makefile.am, include/rdbg/Makefile.am, include/rdbg/i386/Makefile.am, include/rdbg/m68k/Makefile.am, include/rdbg/powerpc/Makefile.am, src/Makefile.am, src/i386/Makefile.am, src/i386/any/Makefile.am, src/m68k/Makefile.am, src/m68k/any/Makefile.am, src/powerpc/Makefile.am, src/powerpc/new_exception_processing/Makefile.am: Reflect having merged configure.ac into ../configure.ac.
Diffstat (limited to '')
-rw-r--r--c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am32
1 files changed, 17 insertions, 15 deletions
diff --git a/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am b/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
index 6d88639bb4..7b45d7f678 100644
--- a/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
+++ b/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
@@ -5,6 +5,8 @@
VPATH = @srcdir@:@srcdir@/..:@srcdir@/../..
+RPCCPUDIR = $(RTEMS_CPU)/new_exception_processing
+
LIBNAME = librdbg
LIB = ${ARCH}/${LIBNAME}.a
@@ -32,14 +34,14 @@ OBJS = $(GEN_C_O_FILES) $(C_O_FILES) $(S_O_FILES)
MAINTAINERCLEANFILES = $(H_FILES) $(GEN_C_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
+include $(top_srcdir)/../../automake/compile.am
+include $(top_srcdir)/../../automake/lib.am
#
# Add local stuff here using +=
#
-FRONTEND = \"$(RTEMS_CPU)/new_exception_processing/remdeb_f.x\"
+FRONTEND = \"$(RPCCPUDIR)/remdeb_f.x\"
$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
$(INSTALL_DATA) $< $@
@@ -50,29 +52,29 @@ $(LIB): ${OBJS}
$(srcdir)/remdeb.h: $(X_FILES)
if RPCTOOLS
@rm -f $@
- ( cd $(top_srcdir)/src; \
+ ( cd $(top_srcdir)/librdbg/src; \
$(RPCGEN) -h -DFRONTEND=$(FRONTEND) \
- -o powerpc/new_exception_processing/remdeb.h remdeb.x )
+ -o $(RPCCPUDIR)/remdeb.h remdeb.x )
endif
$(srcdir)/remdeb_xdr.c: $(X_FILES)
if RPCTOOLS
@rm -f $@
- ( cd $(top_srcdir)/src; \
+ ( cd $(top_srcdir)/librdbg/src; \
$(RPCGEN) -c -DFRONTEND=$(FRONTEND) \
- -o powerpc/new_exception_processing/remdeb_xdr.c remdeb.x )
+ -o $(RPCCPUDIR)/remdeb_xdr.c remdeb.x )
endif
$(srcdir)/remdeb_svc.c: $(X_FILES)
if RPCTOOLS
@rm -f $@ tmpSvc.c
- ( cd $(top_srcdir)/src; \
+ ( cd $(top_srcdir)/librdbg/src; \
$(RPCGEN) -m -DFRONTEND=$(FRONTEND) \
- -o powerpc/new_exception_processing/tmpSvc.c remdeb.x; \
- $(AWK) -f ./awk.svc THEPROG="remdeb.h" powerpc/new_exception_processing/tmpSvc.c \
- > powerpc/new_exception_processing/remdeb_svc.c; \
- sed -e 's/fprintf.*,/printf(/' powerpc/new_exception_processing/remdeb_svc.c > powerpc/new_exception_processing/remdeb_svc.tmp; \
- mv powerpc/new_exception_processing/remdeb_svc.tmp powerpc/new_exception_processing/remdeb_svc.c; \
- rm -f powerpc/new_exception_processing/tmpSvc.c )
+ -o $(RPCCPUDIR)/tmpSvc.c remdeb.x; \
+ $(AWK) -f ./awk.svc THEPROG="remdeb.h" $(RPCCPUDIR)/tmpSvc.c \
+ > $(RPCCPUDIR)/remdeb_svc.c; \
+ sed -e 's/fprintf.*,/printf(/' $(RPCCPUDIR)/remdeb_svc.c > $(RPCCPUDIR)/remdeb_svc.tmp; \
+ mv $(RPCCPUDIR)/remdeb_svc.tmp $(RPCCPUDIR)/remdeb_svc.c; \
+ rm -f $(RPCCPUDIR)/tmpSvc.c )
endif
$(PROJECT_INCLUDE)/rdbg/remdeb.h: $(srcdir)/remdeb.h
@@ -89,4 +91,4 @@ all-local: ${ARCH} $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
EXTRA_DIST = remdeb_f.x $(GEN_C_FILES)
-include $(top_srcdir)/../../../automake/local.am
+include $(top_srcdir)/../../automake/local.am