summaryrefslogtreecommitdiffstats
path: root/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-13 21:07:22 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-13 21:07:22 +0000
commit4c3ab8463610365de864b0f769d210ee914a71ec (patch)
tree3888952129deab34466f212e5293446a19b5763a /c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
parentAll m68k BSPs now build with new ELF style linkcmds. (diff)
downloadrtems-4c3ab8463610365de864b0f769d210ee914a71ec.tar.bz2
Patch rtems-rc-20000104-17.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that addresses the librdbg/rpcgen related problems: Changes: * All rpcgen generated files are now kept inside of the source tree * Fix librdbg/configure to correctly detect presence of rpcgen and awk * Use rpcgen -m to generated remdeb_svc.c * Remove msgout/_msgout from awk.svc * minor cleanups to librdbg/configure.in ATTENTION --- IMPORTANT: * With keeping rpc-generated files pre-build inside of the source tree, you as the packager of RTEMS have to ensure that timestamps are correctly set up: The generated files must not be older than the *.x files. * This is extraordinarily important when - putting the package on read-only media - after checking out from CVS - after modifications to the *.x files * If one of the *.x files is modified you have to either - build for i386/pc386 and powerpc/mcp750 - or to invoke the same rpcgen calls as the librdbg/src/<cpu>/<bsp>/Makefile.am do manually before checking-in the files to CVS. Proposal: We could add something to bootstrap for touching the rpcgen-generated sources and/or to manually regenerate them. NOTE FROM JOEL: Ralf proposed modifying bootstrap to handle rpcgen. I think this is the best solution as it is something already done in the snapshot procedure.
Diffstat (limited to '')
-rw-r--r--c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am66
1 files changed, 36 insertions, 30 deletions
diff --git a/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am b/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
index 9b178e2c36..758a69de50 100644
--- a/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
+++ b/c/src/librdbg/src/powerpc/new_exception_processing/Makefile.am
@@ -33,55 +33,61 @@ OBJS = $(GEN_C_O_FILES) $(C_O_FILES) $(S_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../automake/lib.am
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rdbg \
-$(PROJECT_INCLUDE)/rdbg/remdeb.h
-
-$(PROJECT_INCLUDE)/rdbg:
- @$(mkinstalldirs) $@
-
-TMPINSTALL_FILES += \
-$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIBVARIANT).a
-
#
# Add local stuff here using +=
#
-CLEANFILES += $(LIB) $(H_FILES) $(GEN_C_FILES)
+MAINTAINERCLEANFILES += $(H_FILES) $(GEN_C_FILES)
FRONTEND = \"$(RTEMS_CPU)/mcp750/remdeb_f.x\"
$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIBVARIANT).a: $(LIB)
$(INSTALL_DATA) $< $@
-all: ${ARCH} $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
-
$(LIB): ${OBJS}
$(make-library)
-remdeb.h: $(X_FILES)
+$(srcdir)/remdeb.h: $(X_FILES)
+if RPCTOOLS
@rm -f $@
- ( pwd=`pwd`; cd $(srcdir)/../..; \
+ ( cd $(top_srcdir)/src; \
$(RPCGEN) -h -DFRONTEND=$(FRONTEND) \
- -o $$pwd/$@ remdeb.x )
-
-$(PROJECT_INCLUDE)/rdbg/remdeb.h: remdeb.h
- $(INSTALL_DATA) $< $@
-
-remdeb_xdr.c: $(X_FILES)
+ -o powerpc/mcp750/remdeb.h remdeb.x )
+endif
+$(srcdir)/remdeb_xdr.c: $(X_FILES)
+if RPCTOOLS
@rm -f $@
- ( pwd=`pwd`; cd $(srcdir)/../..; \
+ ( cd $(top_srcdir)/src; \
$(RPCGEN) -c -DFRONTEND=$(FRONTEND) \
- -o $$pwd/$@ remdeb.x )
+ -o powerpc/mcp750/remdeb_xdr.c remdeb.x )
+endif
-remdeb_svc.c: $(X_FILES)
+$(srcdir)/remdeb_svc.c: $(X_FILES)
+if RPCTOOLS
@rm -f $@ tmpSvc.c
- ( pwd=`pwd`; cd $(srcdir)/../..; \
- $(RPCGEN) -s udp -DFRONTEND=$(FRONTEND) \
- -o $$pwd/tmpSvc.c remdeb.x )
- $(AWK) -f $(srcdir)/../../awk.svc THEPROG="remdeb.h" tmpSvc.c >$@
- @rm -f tmpSvc.c
+ ( cd $(top_srcdir)/src; \
+ $(RPCGEN) -m -DFRONTEND=$(FRONTEND) \
+ -o powerpc/mcp750/tmpSvc.c remdeb.x; \
+ $(AWK) -f ./awk.svc THEPROG="remdeb.h" powerpc/mcp750/tmpSvc.c \
+ > powerpc/mcp750/remdeb_svc.c; \
+ rm -f powerpc/mcp750/tmpSvc.c )
+endif
+
+$(PROJECT_INCLUDE)/rdbg/remdeb.h: $(srcdir)/remdeb.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/rdbg:
+ @$(mkinstalldirs) $@
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rdbg \
+$(PROJECT_INCLUDE)/rdbg/remdeb.h
+
+TMPINSTALL_FILES += \
+$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIBVARIANT).a
+
+all-local: ${ARCH} $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
-EXTRA_DIST = remdeb_f.x
+EXTRA_DIST = remdeb_f.x $(GEN_C_FILES)
include $(top_srcdir)/../../../automake/local.am