summaryrefslogtreecommitdiffstats
path: root/c/src/libnetworking/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:36:27 +0000
commite6d8fe4717c301925408786aee585fb96912e445 (patch)
tree18a65119b8150bfc661d3fee629eb8361d4e7555 /c/src/libnetworking/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e6d8fe4717c301925408786aee585fb96912e445.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am, arpa/Makefile.am, machine/Makefile.am, net/Makefile.am, netinet/Makefile.am, nfs/Makefile.am, rtems/Makefile.am, rtems_servers/Makefile.am, rtems_webserver/Makefile.am, sys/Makefile.am, vm/Makefile.am: Apply include_*HEADERS instead of H_FILES. * include/Makefile.am: Remove. * Makefile.am: Add handling of *.h files. * configure.in: Remove include/Makefile.
Diffstat (limited to 'c/src/libnetworking/Makefile.am')
-rw-r--r--c/src/libnetworking/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/c/src/libnetworking/Makefile.am b/c/src/libnetworking/Makefile.am
index 7f09e1d21b..57f87c7b5d 100644
--- a/c/src/libnetworking/Makefile.am
+++ b/c/src/libnetworking/Makefile.am
@@ -5,11 +5,24 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I ../../../aclocal
-SUBDIRS = include arpa kern machine sys vm lib libc net netinet nfs rtems \
+SUBDIRS = arpa kern machine sys vm lib libc net netinet nfs rtems \
rtems_servers pppd modem rtems_webserver wrapup
-EXTRA_DIST = CHANGELOG bpfilter.h loop.h netdb.h opt_ipfw.h opt_mrouting.h \
+include_HEADERS = \
+ bpfilter.h loop.h netdb.h opt_ipfw.h opt_mrouting.h \
opt_tcpdebug.h poll.h resolv.h syslog.h memory.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE) \
+ $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = CHANGELOG
+
include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am