summaryrefslogtreecommitdiffstats
path: root/c/src/libmisc/wrapup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-08 22:33:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-08 22:33:25 +0000
commit70810dcd8970194d96f685ffe4af890911e273c5 (patch)
treecade3ccf39b9bcabc04e7b1ce9105a83f80b177d /c/src/libmisc/wrapup/Makefile.am
parentchanged version to 4.5.0-beta1 (diff)
downloadrtems-70810dcd8970194d96f685ffe4af890911e273c5.tar.bz2
Patches rtems-rc-20000204-0.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that contains: * Removes remaining (now illegal) references to $(SRC) from a couple of Makefile.ams * Removes duplicate AC_CONFIG_SUBDIRS macro from c/configure.in * Moves ENABLE_LIBCDIR into RTEMS_PROG_C[C|XX]_FOR_TARGET (hides LIBCDIR from most configure scripts, i.e. LIBCDIR becomes less visible) * Adds RTEMS_PROG_C[C|XX]_FOR_TARGET and RTEMS_CANONICALIZE_TOOLS to libbsp/*/configure.ins (A minor bug in previous implementations, which only has an impact when switching to GNU/Cygnus canonicalization) * Cleans up several bogus comments. * Removes MKLIB * Switches the version number to 4.5.0 (for testing version number handling)
Diffstat (limited to 'c/src/libmisc/wrapup/Makefile.am')
-rw-r--r--c/src/libmisc/wrapup/Makefile.am27
1 files changed, 13 insertions, 14 deletions
diff --git a/c/src/libmisc/wrapup/Makefile.am b/c/src/libmisc/wrapup/Makefile.am
index d5021a7be0..5d43b326b3 100644
--- a/c/src/libmisc/wrapup/Makefile.am
+++ b/c/src/libmisc/wrapup/Makefile.am
@@ -1,23 +1,20 @@
-##
-## $Id$
-##
+##
+## $Id$
+##
AUTOMAKE_OPTIONS = foreign 1.4
LIBNAME = libmisc
-LIB = ${ARCH}/$(LIBNAME).a
+LIB = $(ARCH)/$(LIBNAME).a
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../automake/lib.am
-TMP_LIBS = ../monitor/$(ARCH)/libmonitor-tmp.a ../untar/$(ARCH)/libuntar-tmp.a \
- ../stackchk/$(ARCH)/libstackchk-tmp.a ../cpuuse/$(ARCH)/libcpuuse-tmp.a \
- ../rtmonuse/$(ARCH)/librtmonuse-tmp.a \
+TMP_LIBS = ../monitor/$(ARCH)/libmonitor-tmp.a \
+ ../untar/$(ARCH)/libuntar-tmp.a ../stackchk/$(ARCH)/libstackchk-tmp.a \
+ ../cpuuse/$(ARCH)/libcpuuse-tmp.a ../rtmonuse/$(ARCH)/librtmonuse-tmp.a \
../dumpbuf/$(ARCH)/libdumpbuf-tmp.a
-TMPINSTALL_FILES += \
-$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
-
$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
$(INSTALL_DATA) $< $@
@@ -29,12 +26,14 @@ $(LIB): $(TMP_LIBS)
$(RM) $@
$(RM) -r $(ARCH)
mkdir $(ARCH)
- cd $(ARCH); for lib in $^; do \
- $(AR) -xv ../$$lib; \
- done
+ cd $(ARCH); for lib in $^; do $(AR) -xv ../$$lib; done
$(AR) ruv $@ $(ARCH)/*
$(RANLIB) $@
-all: ${ARCH} $(LIB) $(TMPINSTALL_FILES)
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
+
+all-local: $(ARCH) $(LIB) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(LIB)
include $(top_srcdir)/../../../automake/local.am