summaryrefslogtreecommitdiffstats
path: root/c/src/libmisc/shell/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-04-20 20:35:45 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-04-20 20:35:45 +0000
commitdd74e612f1ffe208ad1e20f28ac4da3f08764879 (patch)
tree52d3f65d7197ccbe922d6c2e5b211da8be2ec552 /c/src/libmisc/shell/Makefile.am
parent2001-04-20 Radzislaw Galler <rgaller@et.put.poznan.pl> (diff)
downloadrtems-dd74e612f1ffe208ad1e20f28ac4da3f08764879.tar.bz2
2001-04-20 Correo Fernando-ruiz <correo@fernando-ruiz.com>
* Added initial shell functionality. * Makefile.am, configure.in, wrapup/Makefile.am: * shell/.cvsignore, shell/Makefile.am, shell/README, shell/cmds.c, shell/shell.c, shell/shell.h: New files.
Diffstat (limited to 'c/src/libmisc/shell/Makefile.am')
-rw-r--r--c/src/libmisc/shell/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/c/src/libmisc/shell/Makefile.am b/c/src/libmisc/shell/Makefile.am
new file mode 100644
index 0000000000..814cf40c44
--- /dev/null
+++ b/c/src/libmisc/shell/Makefile.am
@@ -0,0 +1,44 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+include_rtemsdir = $(includedir)/rtems
+
+LIBNAME = libshell-tmp
+LIB = $(ARCH)/$(LIBNAME).a
+
+C_FILES = cmds.c shell.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+include_rtems_HEADERS = shell.h
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
+
+all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = README shell.c cmds.c shell.h
+
+include $(top_srcdir)/../../../automake/local.am