summaryrefslogtreecommitdiffstats
path: root/c/src/libmisc/rootfs/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-17 18:30:03 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-17 18:30:03 +0000
commitae307352678a0b2e2f7cf93c21793f4b407ee369 (patch)
tree78277ea6dd0e8a1365cf5f40d4c3ae77663351ac /c/src/libmisc/rootfs/Makefile.am
parent2002-05-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-ae307352678a0b2e2f7cf93c21793f4b407ee369.tar.bz2
2002-05-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* rootfs/.cvsignore: Remove. * rootfs/Makefile.am: Remove. * rootfs/mkrootfs.h: Remove. * rootfs/mkrootfs.c: Remove. * configure.ac: Remove rootfs and NETWORKING macros. * wrapup/Makefile.am: Remove rootfs and HAS_NETWORKING.
Diffstat (limited to '')
-rw-r--r--c/src/libmisc/rootfs/Makefile.am44
1 files changed, 0 insertions, 44 deletions
diff --git a/c/src/libmisc/rootfs/Makefile.am b/c/src/libmisc/rootfs/Makefile.am
deleted file mode 100644
index 3a81ec7e11..0000000000
--- a/c/src/libmisc/rootfs/Makefile.am
+++ /dev/null
@@ -1,44 +0,0 @@
-##
-## $Id$
-##
-
-
-LIBNAME = librootfs-tmp
-LIB = $(ARCH)/$(LIBNAME).a
-
-C_FILES = mkrootfs.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-
-include_rtemsdir = $(includedir)/rtems
-include_rtems_HEADERS = mkrootfs.h
-
-OBJS = $(C_O_FILES)
-
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
-$(PROJECT_INCLUDE)/rtems:
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/rtems/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(LIB): $(OBJS)
- $(make-library)
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
- $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
-
-if HAS_NETWORKING
-all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
-endif
-
-.PRECIOUS: $(LIB)
-
-EXTRA_DIST = README mkrootfs.c
-
-include $(top_srcdir)/../../../automake/local.am