summaryrefslogtreecommitdiffstats
path: root/c/src/libmisc/rootfs/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-09-21 14:02:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-09-21 14:02:27 +0000
commit2543311206e8f64cddd8a633e3f145aadd262712 (patch)
tree3d7ad2ed749e4c9b4f5d68c4e1a2bce77f11a0b8 /c/src/libmisc/rootfs/Makefile.am
parent2001-09-14 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-2543311206e8f64cddd8a633e3f145aadd262712.tar.bz2
2001-09-14 Joel Sherrill <joel@OARcorp.com>
* configure.in, rootfs/Makefile.am: Added conditional to make sure rootfs does not get built with networking is disabled. Also added include of compile.am to rootfs/Makefile.am. * wrapup/Makefile.am: Added rootfs conditionally if networking enabled.
Diffstat (limited to 'c/src/libmisc/rootfs/Makefile.am')
-rw-r--r--c/src/libmisc/rootfs/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/c/src/libmisc/rootfs/Makefile.am b/c/src/libmisc/rootfs/Makefile.am
index 891cbd88e1..28a4fd4b5a 100644
--- a/c/src/libmisc/rootfs/Makefile.am
+++ b/c/src/libmisc/rootfs/Makefile.am
@@ -15,6 +15,7 @@ H_FILES = mkrootfs.h
OBJS = $(C_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
$(PROJECT_INCLUDE)/rtems:
@@ -32,7 +33,9 @@ $(LIB): $(OBJS)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
$(H_FILES:%=$(PROJECT_INCLUDE)/rtems/%)
+if HAS_NETWORKING
all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
+endif
.PRECIOUS: $(LIB)