summaryrefslogtreecommitdiffstats
path: root/c/src/libmisc/capture/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-15 16:36:10 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-05-15 16:36:10 +0000
commita923a82d2d63b29165b249bae6ad46bb045290b2 (patch)
treeac6f3f8aedb59311d3bb95cdca06a8ea93756f98 /c/src/libmisc/capture/Makefile.am
parent2002-05-15 Chris Johns <ccj@acm.org> (diff)
downloadrtems-a923a82d2d63b29165b249bae6ad46bb045290b2.tar.bz2
2002-05-16 Chris Johns <ccj@acm.org>
* Per PR194, added the Capture engine. * capture/Makefile.am, capture/README, capture/capture-cli.c, capture/capture-cli.h, capture/capture.c, capture/capture.h, capture/.cvsignore: New files. * Makefile.am, configure.ac, wrapup/Makefile.am: Modified to reflect addition.
Diffstat (limited to 'c/src/libmisc/capture/Makefile.am')
-rw-r--r--c/src/libmisc/capture/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/c/src/libmisc/capture/Makefile.am b/c/src/libmisc/capture/Makefile.am
new file mode 100644
index 0000000000..fe533b265e
--- /dev/null
+++ b/c/src/libmisc/capture/Makefile.am
@@ -0,0 +1,44 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+include_rtemsdir = $(includedir)/rtems
+
+LIBNAME = libcapture-tmp
+LIB = $(ARCH)/$(LIBNAME).a
+
+C_FILES = capture.c capture-cli.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+include_rtems_HEADERS = capture.h capture-cli.h
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/%)
+
+all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = README capture.c capture-cli.c
+
+include $(top_srcdir)/../../../automake/local.am