summaryrefslogtreecommitdiffstats
path: root/c/src/libchip/rtc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-07-25 06:35:06 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-07-25 06:35:06 +0000
commitc7ff624cffbb9c9b3c5161ee828f3f00efd2d326 (patch)
treecda1bd24ef8ae701f941c21db0788f75451fdbd0 /c/src/libchip/rtc/Makefile.am
parent2003-07-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-c7ff624cffbb9c9b3c5161ee828f3f00efd2d326.tar.bz2
2003-07-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* ide/Makefile.am, network/Makefile.am, rtc/Makefile.am, serial/Makefile.am: Add conditional LIBCHIP. Conditionally build include-dirs.
Diffstat (limited to 'c/src/libchip/rtc/Makefile.am')
-rw-r--r--c/src/libchip/rtc/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/c/src/libchip/rtc/Makefile.am b/c/src/libchip/rtc/Makefile.am
index 09ba595c28..2e59036faf 100644
--- a/c/src/libchip/rtc/Makefile.am
+++ b/c/src/libchip/rtc/Makefile.am
@@ -3,8 +3,6 @@
##
-include_libchipdir = $(includedir)/libchip
-
LIBNAME = librtcio
LIB = $(ARCH)/$(LIBNAME).a
@@ -14,11 +12,11 @@ C_FILES = rtcprobe.c icm7170.c icm7170_reg.c icm7170_reg2.c icm7170_reg4.c \
OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-include_libchip_HEADERS = rtc.h icm7170.h m48t08.h
include $(top_srcdir)/../../automake/compile.am
include $(top_srcdir)/../../automake/lib.am
+
PREINSTALL_FILES = $(PROJECT_INCLUDE)/libchip \
$(include_libchip_HEADERS:%=$(PROJECT_INCLUDE)/libchip/%)
@@ -30,11 +28,15 @@ $(PROJECT_INCLUDE)/libchip/%.h: %.h
#
# Add local stuff here using +=
#
+if LIBCHIP
+include_libchipdir = $(includedir)/libchip
+include_libchip_HEADERS = rtc.h icm7170.h m48t08.h
$(LIB): $(OBJS)
$(make-library)
all-local: $(ARCH) $(PREINSTALL_FILES) $(LIB)
+endif
DOC_FILES = README.ds1643 README.icm7170 README.m48t08 README.m48t18 STATUS