summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sparc/syscall/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libcpu/sparc/syscall/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/lib/libcpu/sparc/syscall/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sparc/syscall/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/c/src/lib/libcpu/sparc/syscall/Makefile.am b/c/src/lib/libcpu/sparc/syscall/Makefile.am
index 1466361945..e0246b2829 100644
--- a/c/src/lib/libcpu/sparc/syscall/Makefile.am
+++ b/c/src/lib/libcpu/sparc/syscall/Makefile.am
@@ -4,15 +4,14 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/syscall.rel
+PGM = $(ARCH)/syscall.rel
## Assembly sources
S_FILES = syscall.S
H_FILES = syscall.h
-noinst_HEADERS = $(H_FILES)
-syscall_rel_OBJECTS = $(S_FILES:%.S=${ARCH}/%.o)
+syscall_rel_OBJECTS = $(S_FILES:%.S=$(ARCH)/%.o)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../../../automake/lib.am
@@ -26,11 +25,13 @@ AM_CFLAGS = $(CFLAGS_OS_V)
$(PGM): $(syscall_rel_OBJECTS)
$(make-rel)
-all-local: ${ARCH} $(PGM)
-
-EXTRA_DIST = $(S_FILES)
-
# the .rel file built here will be put into libbsp.a by
# libbsp/sparc/BSP/wrapup/Makefile
+all-local: $(ARCH) $(syscall_rel_OBJECTS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = syscall.S syscall.h
+
include $(top_srcdir)/../../../../../automake/local.am