summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sparc/reg_win/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:50:45 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:50:45 +0000
commitbc2f04f8a8192e148ca9832c49c1c73a445f4310 (patch)
tree12dc7cb8f8eb044a52ba59ee466823066e215513 /c/src/lib/libcpu/sparc/reg_win/Makefile.am
parentPatch rtems-rc-20000104-11.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-bc2f04f8a8192e148ca9832c49c1c73a445f4310.tar.bz2
Patch rtems-rc-20000104-13.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which does the following: * some cleanups, fixes, addtions to the libbsp automake transition patches * The missing Automake transistion patches all libcpu/<cpu>/<variant>/* previously not yet been converted to automake (libcpu/powerpc, libcpu/hppa1.1, libcpu/mips64orion, libcpu/sparc) => With this patch, libcpu/*/* is under full automake control. NOTES: * This patch is tested by building for random set of bsps affected by this patch, but not tested for all BSPs. * The parts of this patch related to libcpu/powerpc fix many small bugs inside of those Makefiles. * Have a look into libcpu/powerpc/mpc6xx/, which is in rather bad shape, IMO. Obviously most subdirectories seem to be build but are not included into libcpu.a by wrapup/Makefile. Addtionally, no actual BSP uses this cpu-variant subdirectory. Furthermore libcpu/powerpc/mpc6xx has a different directory layout than all other powerpc/<variant>/ directories. Joel's note: I agree but the issue is that there is a conflict between including timer or clock in libcpu/XXX/wrapup/Makefile.* and letting a BSP specifically decide to pick it up. There is no clear solution to this at the moment.
Diffstat (limited to 'c/src/lib/libcpu/sparc/reg_win/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sparc/reg_win/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sparc/reg_win/Makefile.am b/c/src/lib/libcpu/sparc/reg_win/Makefile.am
new file mode 100644
index 0000000000..b41bfba876
--- /dev/null
+++ b/c/src/lib/libcpu/sparc/reg_win/Makefile.am
@@ -0,0 +1,31 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = ${ARCH}/reg_win.rel
+
+S_FILES = window.S
+reg_win_rel_OBJECTS = $(S_FILES:%.S=${ARCH}/%.o)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+AM_CFLAGS = $(CFLAGS_OS_V)
+
+$(PGM): $(reg_win_rel_OBJECTS)
+ $(make-rel)
+
+all-local: ${ARCH} $(PGM)
+
+# the .rel file built here will be put into libbsp.a by
+# libbsp/sparc/BSP/wrapup/Makefile
+
+EXTRA_DIST = $(S_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am