summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7750/sci/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-15 18:01:12 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-15 18:01:12 +0000
commit12ae6d9e06e204ffec3669b22b91d4932b3c90e5 (patch)
tree45eb65a3d07bc230fe66e4565182a2ef231e47d1 /c/src/lib/libcpu/sh/sh7750/sci/Makefile.am
parent2001-10-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-12ae6d9e06e204ffec3669b22b91d4932b3c90e5.tar.bz2
2001-10-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/sh4uart.h: move to include/sh/sh4uart.h. * include/ispsh7750.h: move to include/rtems/score/ispsh7750.h. * include/iosh7750.h: move include/rtems/score/iosh7750.h. * include/sh7750_regs.h: move to include/rtems/score/sh7750_regs.h. * include/rtems/score/ipl.h: move to include/rtems/score/ipl.h. * include/rtems/score/sh4_regs.h: Reintroduce from Alexandra Kossovsky's original sources. * include/Makefile.am: reflect changes above, remove EXTRA_DIST, require automake 1.5. * sci/Makefile.am: Disable compilation of console.c. * sci/sh4uart.c: include <sh/sh4uart.h>, add SH7750_SCSMR_CHK_S, remove SH4_CPU_HZ_Frequency; * score/isph7750.c: Remove #if !defined(sh7750), include sh4_regs.h.
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7750/sci/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7750/sci/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/sh/sh7750/sci/Makefile.am b/c/src/lib/libcpu/sh/sh7750/sci/Makefile.am
index e37a7e7984..03ce1e95c6 100644
--- a/c/src/lib/libcpu/sh/sh7750/sci/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7750/sci/Makefile.am
@@ -6,7 +6,7 @@ AUTOMAKE_OPTIONS = foreign 1.4
PGM = $(ARCH)/sci.rel
-C_FILES = console.c sh4uart.c
+C_FILES = sh4uart.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -26,4 +26,8 @@ all-local: $(ARCH) $(OBJS) $(PGM)
.PRECIOUS: $(PGM)
+## FIXME: Moved to libbsp/sh/<BSP>/console/
+## Needs to be reworked to be usable here.
+EXTRA_DIST = console.c
+
include $(top_srcdir)/../../../../../../automake/local.am