summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7750/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-15 18:01:12 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-15 18:01:12 +0000
commit12ae6d9e06e204ffec3669b22b91d4932b3c90e5 (patch)
tree45eb65a3d07bc230fe66e4565182a2ef231e47d1 /c/src/lib/libcpu/sh/sh7750/include/Makefile.am
parent2001-10-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-12ae6d9e06e204ffec3669b22b91d4932b3c90e5.tar.bz2
2001-10-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/sh4uart.h: move to include/sh/sh4uart.h. * include/ispsh7750.h: move to include/rtems/score/ispsh7750.h. * include/iosh7750.h: move include/rtems/score/iosh7750.h. * include/sh7750_regs.h: move to include/rtems/score/sh7750_regs.h. * include/rtems/score/ipl.h: move to include/rtems/score/ipl.h. * include/rtems/score/sh4_regs.h: Reintroduce from Alexandra Kossovsky's original sources. * include/Makefile.am: reflect changes above, remove EXTRA_DIST, require automake 1.5. * sci/Makefile.am: Disable compilation of console.c. * sci/sh4uart.c: include <sh/sh4uart.h>, add SH7750_SCSMR_CHK_S, remove SH4_CPU_HZ_Frequency; * score/isph7750.c: Remove #if !defined(sh7750), include sh4_regs.h.
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7750/include/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7750/include/Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/c/src/lib/libcpu/sh/sh7750/include/Makefile.am b/c/src/lib/libcpu/sh/sh7750/include/Makefile.am
index 05f257e589..9e0a1cec8a 100644
--- a/c/src/lib/libcpu/sh/sh7750/include/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7750/include/Makefile.am
@@ -2,36 +2,36 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
include_shdir = $(includedir)/sh
include_rtems_scoredir = $(includedir)/rtems/score
-include_sh_HEADERS = sh4uart.h
-include_rtems_score_HEADERS = ispsh7750.h iosh7750.h
+include_sh_HEADERS = sh/sh4uart.h
+include_rtems_score_HEADERS = \
+rtems/score/sh7750_regs.h \
+rtems/score/ipl.h \
+rtems/score/iosh7750.h \
+rtems/score/ispsh7750.h \
+rtems/score/sh4_regs.h
$(PROJECT_INCLUDE)/sh:
$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/sh/%.h: %.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
-TMPINSTALL_FILES = $(PROJECT_INCLUDE)/sh \
- $(include_sh_HEADERS:%=$(PROJECT_INCLUDE)/sh/%) \
- $(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/rtems/score/%)
+TMPINSTALL_FILES = \
+ $(PROJECT_INCLUDE)/sh \
+ $(include_sh_HEADERS:%=$(PROJECT_INCLUDE)/%) \
+ $(PROJECT_INCLUDE)/rtems/score \
+ $(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/%)
all-local: $(TMPINSTALL_FILES)
-# FIXME: What are these files here?
-# They should either be installed or removed
-EXTRA_DIST = \
-ipl.h \
-sh4uart.h \
-sh7750_regs.h
-
include $(top_srcdir)/../../../../../../automake/local.am