summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7750/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 13:19:08 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 13:19:08 +0000
commitba7107616869bff7dc80627eab666fceb5ff4fb5 (patch)
treeb5088da2155c328c23266af163798c7dfb19d1bb /c/src/lib/libcpu/sh/sh7750/configure.ac
parent2001-10-11 Mike Siers <mikes@poliac.com> (diff)
downloadrtems-ba7107616869bff7dc80627eab666fceb5ff4fb5.tar.bz2
2001-10-11 Alexandra Kossovsky <sasha@oktet.ru>
* clock/Makefile.am, clock/ckinit.c, clock/.cvsignore, Makefile.am, include/Makefile.am, include/iosh7750.h, include/ipl.h, include/ispsh7750.h, include/sh4_regs.h, include/sh4uart.h, include/sh7750_regs.h, include/.cvsignore, sci/Makefile.am, sci/console.c, sci/sh4uart.c, sci/.cvsignore, score/Makefile.am, score/cpu_asm.c, score/ispsh7750.c, score/.cvsignore, timer/Makefile.am, timer/timer.c, timer/.cvsignore, configure.ac, .cvsignore, ChangeLog: New files. Reviewed and updated to latest automake and autoconf standards by Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7750/configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sh/sh7750/configure.ac b/c/src/lib/libcpu/sh/sh7750/configure.ac
new file mode 100644
index 0000000000..bf31dc3299
--- /dev/null
+++ b/c/src/lib/libcpu/sh/sh7750/configure.ac
@@ -0,0 +1,37 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([include])
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libcpu-sh-sh7750,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_BARE
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+clock/Makefile
+include/Makefile
+score/Makefile
+sci/Makefile
+timer/Makefile])
+AC_OUTPUT