summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7750/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 12:03:28 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 12:03:28 +0000
commitf6273a005c8ddec05036568f80e4386e4f9ee628 (patch)
tree3d412c2d7ae4f7c47a130c9cfc1a78bba577e829 /c/src/lib/libcpu/sh/sh7750/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-f6273a005c8ddec05036568f80e4386e4f9ee628.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Reformat. Use dirstamps for preinstallation.
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7750/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7750/Makefile.am60
1 files changed, 39 insertions, 21 deletions
diff --git a/c/src/lib/libcpu/sh/sh7750/Makefile.am b/c/src/lib/libcpu/sh/sh7750/Makefile.am
index 7ef57f9022..7c81cd6488 100644
--- a/c/src/lib/libcpu/sh/sh7750/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7750/Makefile.am
@@ -13,27 +13,9 @@ include_shdir = $(includedir)/sh
include_rtems_scoredir = $(includedir)/rtems/score
include_sh_HEADERS = include/sh/sh4uart.h
-include_rtems_score_HEADERS = \
-include/rtems/score/sh7750_regs.h \
-include/rtems/score/ipl.h \
-include/rtems/score/iosh7750.h \
-include/rtems/score/ispsh7750.h \
-include/rtems/score/sh4_regs.h
-
-$(PROJECT_INCLUDE)/sh:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems/score:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/%.h: include/%.h
- $(INSTALL_DATA) $< $@
-
-PREINSTALL_FILES = \
- $(PROJECT_INCLUDE)/sh \
- $(include_sh_HEADERS:include/%=$(PROJECT_INCLUDE)/%) \
- $(PROJECT_INCLUDE)/rtems/score \
- $(include_rtems_score_HEADERS:include/%=$(PROJECT_INCLUDE)/%)
+include_rtems_score_HEADERS = include/rtems/score/sh7750_regs.h \
+ include/rtems/score/ipl.h include/rtems/score/iosh7750.h \
+ include/rtems/score/ispsh7750.h include/rtems/score/sh4_regs.h
all-local: $(TMPINSTALL_FILES)
@@ -95,4 +77,40 @@ all-local: $(ARCH) $(PGMS) $(TMPINSTALL_FILES)
.PRECIOUS: $(PGMS)
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/sh/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/sh
+ @: > $(PROJECT_INCLUDE)/sh/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/$(dirstamp)
+
+$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
+ @: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+
+$(PROJECT_INCLUDE)/sh/sh4uart.h: include/sh/sh4uart.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/sh4uart.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/sh4uart.h
+
+$(PROJECT_INCLUDE)/rtems/score/sh7750_regs.h: include/rtems/score/sh7750_regs.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/sh7750_regs.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/sh7750_regs.h
+
+$(PROJECT_INCLUDE)/rtems/score/ipl.h: include/rtems/score/ipl.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/ipl.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ipl.h
+
+$(PROJECT_INCLUDE)/rtems/score/iosh7750.h: include/rtems/score/iosh7750.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/iosh7750.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/iosh7750.h
+
+$(PROJECT_INCLUDE)/rtems/score/ispsh7750.h: include/rtems/score/ispsh7750.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/ispsh7750.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ispsh7750.h
+
+$(PROJECT_INCLUDE)/rtems/score/sh4_regs.h: include/rtems/score/sh4_regs.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/sh4_regs.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/sh4_regs.h
+
include $(top_srcdir)/../../../../automake/local.am