summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7750/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 06:42:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 06:42:49 +0000
commitb55e727e6d4e7452a1e858801d9dbc803429b2c5 (patch)
tree6ac880656ebd813c6e4803a2a98a38f4d13bc8bf /c/src/lib/libcpu/sh/sh7750/Makefile.am
parent2004-01-20 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-b55e727e6d4e7452a1e858801d9dbc803429b2c5.tar.bz2
2003-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Unconditionally build subdirs sh7032, sh7045, sh7750. * configure.ac: Merge-in sh7032/configure.ac, sh7045/configure.ac, sh7750/configure.ac. Add AM_CONDITIONALS sh7032, sh7045, sh7750. * sh7032/Makefile.am, sh7045/Makefile.am, sh7750/Makefile.am: Reflect changes above. Add PREINSTALL_DIRS. * sh7032/configure.ac, sh7045/configure.ac, sh7750/configure.ac: Remove. * sh7032/.cvsignore, sh7045/.cvsignore, sh7750/.cvsignore: Reflect changes above.
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7750/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7750/Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/c/src/lib/libcpu/sh/sh7750/Makefile.am b/c/src/lib/libcpu/sh/sh7750/Makefile.am
index 2314f70f21..76e39e815f 100644
--- a/c/src/lib/libcpu/sh/sh7750/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7750/Makefile.am
@@ -2,15 +2,14 @@
## $Id$
##
-ACLOCAL_AMFLAGS = -I ../../../../aclocal
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
CLEANFILES =
EXTRA_PROGRAMS =
noinst_DATA =
+if sh7750
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
include_shdir = $(includedir)/sh
@@ -80,22 +79,25 @@ timer_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
timer_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
noinst_DATA += timer$(LIB_VARIANT).rel
+endif
-# --
+## --
all-local: $(PREINSTALL_FILES)
+PREINSTALL_DIRS =
PREINSTALL_FILES =
+if sh7750
$(PROJECT_INCLUDE)/sh/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/sh
@: > $(PROJECT_INCLUDE)/sh/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/sh/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems/score
@: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(PROJECT_INCLUDE)/sh/sh4uart.h: include/sh/sh4uart.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/sh4uart.h
@@ -120,7 +122,9 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ispsh7750.h
$(PROJECT_INCLUDE)/rtems/score/sh4_regs.h: include/rtems/score/sh4_regs.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/sh4_regs.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/sh4_regs.h
+endif
CLEANFILES += $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
-include $(top_srcdir)/../../../../automake/local.am
+include $(top_srcdir)/../../../automake/local.am