summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7750/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-01-02 12:46:12 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-01-02 12:46:12 +0000
commit7722eff74a01b067e39afec14a0af98c3c64dc8a (patch)
treee3042f247e367ca499b4e1feb8dce2e49db91bc1 /c/src/lib/libcpu/sh/sh7750/Makefile.am
parent2005-01-02 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-7722eff74a01b067e39afec14a0af98c3c64dc8a.tar.bz2
2005-01-02 Ralf Corsepius <ralf.corsepius@rtems.org>
* sh7032/Makefile.am, sh7045/Makefile.am, sh7750/Makefile.am: Remove build-variant support.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7750/Makefile.am47
1 files changed, 5 insertions, 42 deletions
diff --git a/c/src/lib/libcpu/sh/sh7750/Makefile.am b/c/src/lib/libcpu/sh/sh7750/Makefile.am
index 0c4d271716..473873f2a6 100644
--- a/c/src/lib/libcpu/sh/sh7750/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7750/Makefile.am
@@ -5,8 +5,7 @@
include $(top_srcdir)/../../../automake/compile.am
CLEANFILES =
-EXTRA_PROGRAMS =
-noinst_DATA =
+noinst_PROGRAMS =
if sh7750
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
@@ -20,64 +19,28 @@ include_rtems_score_HEADERS = include/rtems/score/sh7750_regs.h \
include/rtems/score/ispsh7750.h include/rtems/score/sh4_regs.h
## clock
-EXTRA_PROGRAMS += clock.rel
-CLEANFILES += clock.rel
+noinst_PROGRAMS += clock.rel
clock_rel_SOURCES = clock/ckinit.c
clock_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += clock_g.rel
-CLEANFILES += clock_g.rel
-clock_g_rel_SOURCES = $(clock_rel_SOURCES)
-clock_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-clock_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += clock$(LIB_VARIANT).rel
-
## sci
-EXTRA_PROGRAMS += sci.rel
-CLEANFILES += sci.rel
+noinst_PROGRAMS += sci.rel
sci_rel_SOURCES = sci/sh4uart.c
sci_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
sci_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += sci_g.rel
-CLEANFILES += sci_g.rel
-sci_g_rel_SOURCES = $(sci_rel_SOURCES)
-sci_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-sci_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += sci$(LIB_VARIANT).rel
-
## score
-EXTRA_PROGRAMS += score.rel
-CLEANFILES += score.rel
+noinst_PROGRAMS += score.rel
score_rel_SOURCES = score/cpu_asm.c score/ispsh7750.c
score_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_PROGRAMS += score_g.rel
-CLEANFILES += score_g.rel
-score_g_rel_SOURCES = $(score_rel_SOURCES)
-score_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-score_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += score$(LIB_VARIANT).rel
-
## timer
-EXTRA_PROGRAMS += timer.rel
-CLEANFILES += timer.rel
+noinst_PROGRAMS += timer.rel
timer_rel_SOURCES = timer/timer.c
timer_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-EXTRA_PROGRAMS += timer_g.rel
-CLEANFILES += timer_g.rel
-timer_g_rel_SOURCES = $(timer_rel_SOURCES)
-timer_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-timer_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += timer$(LIB_VARIANT).rel
endif
## --