summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7045/sci/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-08-16 21:08:28 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-08-16 21:08:28 +0000
commit7ae512513f37ccce1d5beeb4807b5b4b765025d7 (patch)
tree72a15dffde7261d72011432627201d87ded2cdac /c/src/lib/libcpu/sh/sh7045/sci/Makefile.am
parent2001-08-01 Radzislaw Galler <rgaller@et.put.poznan.pl> (diff)
downloadrtems-7ae512513f37ccce1d5beeb4807b5b4b765025d7.tar.bz2
2001-08-10 Radzislaw Galler <rgaller@et.put.poznan.pl>
* score/cpu_asm.c (sh_set_irq_priority): Changed interrupt vector number range check and handling of interrupt priority regs to conform SH2 specs. * sci/sci_termios.c: New file. * include/sci_termios.h: New file. * include/Makefile.am (EXTRA_DIST): Added sci_termios.h. (include_sh_HEADERS): Added sci_termios.h. * score/ispsh7045.c (isp): Calling an ISR with immediate argument casued negative sign extension for vector numbers of 128 and above. This was fixed. * sci/sci.c: Cleaned initialization of SCI registers; added necessary setup for new TERMIOS console cooperation
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7045/sci/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7045/sci/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c/src/lib/libcpu/sh/sh7045/sci/Makefile.am b/c/src/lib/libcpu/sh/sh7045/sci/Makefile.am
index 77471af08e..c6b70f7e5e 100644
--- a/c/src/lib/libcpu/sh/sh7045/sci/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7045/sci/Makefile.am
@@ -6,7 +6,7 @@ AUTOMAKE_OPTIONS = foreign 1.4
PGM = $(ARCH)/sci.rel
-C_FILES = sci.c
+C_FILES = sci.c sci_termios.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -26,6 +26,6 @@ all-local: $(ARCH) $(OBJS) $(PGM)
.PRECIOUS: $(PGM)
-EXTRA_DIST = sci.c
+EXTRA_DIST = sci.c sci_termios.c
include $(top_srcdir)/../../../../../../automake/local.am