summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7045/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-14 17:07:54 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-14 17:07:54 +0000
commitac8154305172ebcb347f5563dd3ce17d95b4736b (patch)
tree6f24392d14911a8911b287a8b478016c40cb3a26 /c/src/lib/libcpu/sh/sh7045/configure.in
parentMoved PowerPC cache management code to libcpu. Also compiled (diff)
downloadrtems-ac8154305172ebcb347f5563dd3ce17d95b4736b.tar.bz2
Patch rtems-rc-20000614-sh.tar.gz from Ralf Corsepius
<corsepiu@faw.uni-ulm.de> that migrates the SH port to multilib'ing. This patch involved moving a number of files in the CVS repository, adding new files, and deleting files from their previous location. Ralf gave good instructions (not repeated here) and here are his notes: Note 1: In this version, I did not change the installation points of the headers which are moved inside of the source-tree. This is a temporary hack for not breaking compatibility with 4.5 based BSPs, but will probably not last once having real multilibs (We would have include file conflicts when several BSPs/CPU_MODELS share a common installation prefix). Note 2: I hope not to have broken too much, but I would not be astonished if something goes wrong. Note 3: There are more patches to come :)
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7045/configure.in')
-rw-r--r--c/src/lib/libcpu/sh/sh7045/configure.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sh/sh7045/configure.in b/c/src/lib/libcpu/sh/sh7045/configure.in
new file mode 100644
index 0000000000..604255d64f
--- /dev/null
+++ b/c/src/lib/libcpu/sh/sh7045/configure.in
@@ -0,0 +1,37 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(include)
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libcpu-sh-sh7045,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_BARE
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+
+# Explicitly list all Makefiles here
+AC_OUTPUT(
+Makefile
+clock/Makefile
+include/Makefile
+score/Makefile
+null/Makefile
+sci/Makefile
+timer/Makefile)