summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7045/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-01-16 10:52:19 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-01-16 10:52:19 +0000
commitec1898b266796d513557e3ba0341b15622f067c7 (patch)
treef14a33b528d751baa85b703115b3939c7c939172 /c/src/lib/libcpu/sh/sh7045/Makefile.am
parent2003-01-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-ec1898b266796d513557e3ba0341b15622f067c7.tar.bz2
2003-01-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in subdir Makefile.ams * configure.ac: Reflect changes above. * score/Makefile.am: Removed. * sci/Makefile.am: Removed. * timer/Makefile.am: Removed. * clock/Makefile.am: Removed.
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7045/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7045/Makefile.am62
1 files changed, 58 insertions, 4 deletions
diff --git a/c/src/lib/libcpu/sh/sh7045/Makefile.am b/c/src/lib/libcpu/sh/sh7045/Makefile.am
index 89e57442d7..f7dd968aed 100644
--- a/c/src/lib/libcpu/sh/sh7045/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7045/Makefile.am
@@ -4,7 +4,8 @@
ACLOCAL_AMFLAGS = -I ../../../../../../aclocal
-SUBDIRS = . score clock sci timer
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
@@ -24,11 +25,64 @@ $(PROJECT_INCLUDE)/sh/%.h: include/%.h
$(PROJECT_INCLUDE)/rtems/score/%.h: include/%.h
$(INSTALL_DATA) $< $@
-TMPINSTALL_FILES = $(PROJECT_INCLUDE)/sh \
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/sh \
$(include_sh_HEADERS:include/%=$(PROJECT_INCLUDE)/sh/%) \
$(include_rtems_score_HEADERS:include/%=$(PROJECT_INCLUDE)/rtems/score/%)
-all-local: $(TMPINSTALL_FILES)
+# clock
+
+PGMS = $(ARCH)/clock.rel
+
+clock_C_FILES = clock/ckinit.c
+clock_rel_OBJECTS = $(clock_C_FILES:clock/%.c=$(ARCH)/%.$(OBJEXT))
+EXTRA_DIST = $(clock_C_FILES)
+
+${ARCH}/%.$(OBJEXT): clock/%.c
+ ${COMPILE} -o $@ -c $<
+${ARCH}/clock.rel: $(clock_rel_OBJECTS)
+ ${make-rel}
+
+# sci
+
+PGMS += $(ARCH)/sci.rel
+
+sci_C_FILES = sci/sci.c sci/sci_termios.c
+sci_rel_OBJECTS = $(sci_C_FILES:sci/%.c=$(ARCH)/%.$(OBJEXT))
+EXTRA_DIST += $(sci_C_FILES)
+
+${ARCH}/%.$(OBJEXT): sci/%.c
+ ${COMPILE} -o $@ -c $<
+${ARCH}/sci.rel: $(sci_rel_OBJECTS)
+ ${make-rel}
+
+# score
+
+PGMS += $(ARCH)/score.rel
+
+score_C_FILES = score/cpu_asm.c score/ispsh7045.c
+score_rel_OBJECTS = $(score_C_FILES:score/%.c=$(ARCH)/%.$(OBJEXT))
+EXTRA_DIST += $(score_C_FILES)
+
+${ARCH}/%.$(OBJEXT): score/%.c
+ ${COMPILE} -o $@ -c $<
+${ARCH}/score.rel: $(score_rel_OBJECTS)
+ ${make-rel}
+
+## timer
+
+PGMS += $(ARCH)/timer.rel
+
+timer_C_FILES = timer/timer.c
+timer_rel_OBJECTS = $(timer_C_FILES:timer/%.c=$(ARCH)/%.$(OBJEXT))
+EXTRA_DIST += $(timer_C_FILES)
+
+${ARCH}/%.$(OBJEXT): timer/%.c
+ ${COMPILE} -o $@ -c $<
+${ARCH}/timer.rel: $(timer_rel_OBJECTS)
+ ${make-rel}
+
+all-local: $(ARCH) $(PGMS) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(PGMS)
-include $(top_srcdir)/../../../../../../automake/subdirs.am
include $(top_srcdir)/../../../../../../automake/local.am