summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7045/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 15:47:20 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 15:47:20 +0000
commita4666cd54a6bec2af33f9b9e6ed1bef1a717a9cd (patch)
tree8bd6eed6b1cef7a8314fd2e7d58f5bfa8c250807 /c/src/lib/libcpu/sh/sh7045/Makefile.am
parent2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a4666cd54a6bec2af33f9b9e6ed1bef1a717a9cd.tar.bz2
2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Use mkdir_p. Remove dirs from PRE/TMPINSTALL_FILES.
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7045/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7045/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/c/src/lib/libcpu/sh/sh7045/Makefile.am b/c/src/lib/libcpu/sh/sh7045/Makefile.am
index 015a639724..ef732f4b96 100644
--- a/c/src/lib/libcpu/sh/sh7045/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7045/Makefile.am
@@ -75,14 +75,12 @@ all-local: $(PGMS) $(TMPINSTALL_FILES)
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/sh/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)/sh
+ @$(mkdir_p) $(PROJECT_INCLUDE)/sh
@: > $(PROJECT_INCLUDE)/sh/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
+ @$(mkdir_p) $(PROJECT_INCLUDE)/rtems/score
@: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(PROJECT_INCLUDE)/sh/io_types.h: include/io_types.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/io_types.h