summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7032/timer/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libcpu/sh/sh7032/timer/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7032/timer/Makefile.am24
1 files changed, 10 insertions, 14 deletions
diff --git a/c/src/lib/libcpu/sh/sh7032/timer/Makefile.am b/c/src/lib/libcpu/sh/sh7032/timer/Makefile.am
index 1b91bb066c..b72f9ca03b 100644
--- a/c/src/lib/libcpu/sh/sh7032/timer/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7032/timer/Makefile.am
@@ -3,32 +3,28 @@
##
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/timer.rel
-## C source names
-C_FILES = timer.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
-
-H_FILES =
+PGM = $(ARCH)/timer.rel
-## Assembly source names
-S_FILES =
-S_O_FILES = $(S_FILES:%.S=${ARCH}/%.o)
+C_FILES = timer.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-OBJS = $(C_O_FILES) $(S_O_FILES)
+OBJS = $(C_O_FILES)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(RTEMS_ROOT)/make/leaf.cfg
+include $(top_srcdir)/../../../../../automake/lib.am
#
# (OPTIONAL) Add local stuff here using +=
#
-${PGM}: ${OBJS}
+$(PGM): $(OBJS)
$(make-rel)
-all: ${ARCH} $(PGM)
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
-EXTRA_DIST = $(C_FILES) $(S_FILES)
+EXTRA_DIST = timer.c
include $(top_srcdir)/../../../../../automake/local.am