summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-14 17:07:54 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-14 17:07:54 +0000
commitac8154305172ebcb347f5563dd3ce17d95b4736b (patch)
tree6f24392d14911a8911b287a8b478016c40cb3a26 /c/src/lib/libcpu/sh/sh7032/include/Makefile.am
parentMoved PowerPC cache management code to libcpu. Also compiled (diff)
downloadrtems-ac8154305172ebcb347f5563dd3ce17d95b4736b.tar.bz2
Patch rtems-rc-20000614-sh.tar.gz from Ralf Corsepius
<corsepiu@faw.uni-ulm.de> that migrates the SH port to multilib'ing. This patch involved moving a number of files in the CVS repository, adding new files, and deleting files from their previous location. Ralf gave good instructions (not repeated here) and here are his notes: Note 1: In this version, I did not change the installation points of the headers which are moved inside of the source-tree. This is a temporary hack for not breaking compatibility with 4.5 based BSPs, but will probably not last once having real multilibs (We would have include file conflicts when several BSPs/CPU_MODELS share a common installation prefix). Note 2: I hope not to have broken too much, but I would not be astonished if something goes wrong. Note 3: There are more patches to come :)
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7032/include/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/c/src/lib/libcpu/sh/sh7032/include/Makefile.am b/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
index 7d26513f10..b44d68d5c3 100644
--- a/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
@@ -5,6 +5,7 @@
AUTOMAKE_OPTIONS = foreign 1.4
H_FILES = null.h sci.h sh7_pfc.h sh7_sci.h
+SCORE_H_FILES= ispsh7032.h iosh7032.h
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
@@ -15,11 +16,15 @@ $(PROJECT_INCLUDE)/sh:
$(PROJECT_INCLUDE)/sh/%.h: %.h
$(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
TMPINSTALL_FILES += $(PROJECT_INCLUDE)/sh \
- $(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
+ $(H_FILES:%.h=$(PROJECT_INCLUDE)/sh/%.h) \
+ $(SCORE_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
all-local: $(TMPINSTALL_FILES)
EXTRA_DIST = null.h sci.h sh7_pfc.h sh7_sci.h
-include $(top_srcdir)/../../../../../automake/local.am
+include $(top_srcdir)/../../../../../../automake/local.am