summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libcpu/sh/sh7032/include/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/lib/libcpu/sh/sh7032/include/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/sh7032/include/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/c/src/lib/libcpu/sh/sh7032/include/Makefile.am b/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
index feb0333fda..72e931ea32 100644
--- a/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7032/include/Makefile.am
@@ -5,20 +5,21 @@
AUTOMAKE_OPTIONS = foreign 1.4
H_FILES = null.h sci.h sh7_pfc.h sh7_sci.h
-noinst_HEADERS = $(H_FILES)
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
-TMPINSTALL_FILES = $(PROJECT_INCLUDE)/sh \
- $(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
-
$(PROJECT_INCLUDE)/sh:
$(mkinstalldirs) $@
$(PROJECT_INCLUDE)/sh/%.h: %.h
$(INSTALL_DATA) $< $@
+TMPINSTALL_FILES += $(PROJECT_INCLUDE)/sh \
+ $(H_FILES:%=$(PROJECT_INCLUDE)/sh/%)
+
all-local: $(TMPINSTALL_FILES)
+EXTRA_DIST = null.h sci.h sh7_pfc.h sh7_sci.h
+
include $(top_srcdir)/../../../../../automake/local.am