summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7032/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 12:03:28 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 12:03:28 +0000
commitf6273a005c8ddec05036568f80e4386e4f9ee628 (patch)
tree3d412c2d7ae4f7c47a130c9cfc1a78bba577e829 /c/src/lib/libcpu/sh/sh7032/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-f6273a005c8ddec05036568f80e4386e4f9ee628.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Reformat. Use dirstamps for preinstallation.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7032/Makefile.am49
1 files changed, 32 insertions, 17 deletions
diff --git a/c/src/lib/libcpu/sh/sh7032/Makefile.am b/c/src/lib/libcpu/sh/sh7032/Makefile.am
index c84908865e..d5e7f2d45b 100644
--- a/c/src/lib/libcpu/sh/sh7032/Makefile.am
+++ b/c/src/lib/libcpu/sh/sh7032/Makefile.am
@@ -15,23 +15,6 @@ include_rtems_scoredir = $(includedir)/rtems/score
include_sh_HEADERS = include/sci.h include/sh7_pfc.h include/sh7_sci.h
include_rtems_score_HEADERS = include/ispsh7032.h include/iosh7032.h
-$(PROJECT_INCLUDE)/sh:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/sh/%.h: include/%.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE)/rtems/score:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems/score/%.h: include/%.h
- $(INSTALL_DATA) $< $@
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/sh \
- $(include_sh_HEADERS:include/%.h=$(PROJECT_INCLUDE)/sh/%.h) \
- $(PROJECT_INCLUDE)/rtems/score \
- $(include_rtems_score_HEADERS:include/%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
-
# clock
PGMS = $(ARCH)/clock.rel
@@ -101,4 +84,36 @@ all-local: $(ARCH) $(PGMS) $(TMPINSTALL_FILES)
.PRECIOUS: $(PGMS)
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/sh/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/sh
+ @: > $(PROJECT_INCLUDE)/sh/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/$(dirstamp)
+
+$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
+ @: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+
+$(PROJECT_INCLUDE)/sh/sci.h: include/sci.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/sci.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/sci.h
+
+$(PROJECT_INCLUDE)/sh/sh7_pfc.h: include/sh7_pfc.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/sh7_pfc.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/sh7_pfc.h
+
+$(PROJECT_INCLUDE)/sh/sh7_sci.h: include/sh7_sci.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/sh7_sci.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/sh7_sci.h
+
+$(PROJECT_INCLUDE)/rtems/score/ispsh7032.h: include/ispsh7032.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/ispsh7032.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ispsh7032.h
+
+$(PROJECT_INCLUDE)/rtems/score/iosh7032.h: include/iosh7032.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/iosh7032.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/iosh7032.h
+
include $(top_srcdir)/../../../../automake/local.am