summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/sh7032/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-05-11 07:37:48 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-05-11 07:37:48 +0000
commit2289e14354753219af9c6115abc1298a67eb5f29 (patch)
treebed1cd9331fe862a88a9797c10d088fd0b666e2a /c/src/lib/libcpu/sh/sh7032/Makefile.am
parentRemove. (diff)
downloadrtems-2289e14354753219af9c6115abc1298a67eb5f29.tar.bz2
Remove.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/sh7032/Makefile.am90
1 files changed, 0 insertions, 90 deletions
diff --git a/c/src/lib/libcpu/sh/sh7032/Makefile.am b/c/src/lib/libcpu/sh/sh7032/Makefile.am
deleted file mode 100644
index bc1909afb5..0000000000
--- a/c/src/lib/libcpu/sh/sh7032/Makefile.am
+++ /dev/null
@@ -1,90 +0,0 @@
-##
-## $Id$
-##
-
-include $(top_srcdir)/../../../automake/compile.am
-
-CLEANFILES =
-noinst_PROGRAMS =
-
-if sh7032
-# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
-# file name conflicts
-include_shdir = $(includedir)/sh
-include_rtems_scoredir = $(includedir)/rtems/score
-
-include_sh_HEADERS = include/sci.h include/sh7_pfc.h include/sh7_sci.h
-include_rtems_score_HEADERS = include/ispsh7032.h include/iosh7032.h
-
-# clock
-noinst_PROGRAMS += clock.rel
-clock_rel_SOURCES = clock/ckinit.c
-clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
-clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-# delay
-noinst_PROGRAMS += delay.rel
-delay_rel_SOURCES = delay/delay.c
-delay_rel_CPPFLAGS = $(AM_CPPFLAGS)
-delay_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-# sci
-noinst_PROGRAMS += sci.rel
-sci_rel_SOURCES = sci/sci.c
-sci_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sci_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-# score
-noinst_PROGRAMS += score.rel
-score_rel_SOURCES =score/cpu_asm.c score/ispsh7032.c
-score_rel_CPPFLAGS = $(AM_CPPFLAGS)
-score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## timer
-noinst_PROGRAMS += timer.rel
-timer_rel_SOURCES = timer/timer.c
-timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
-timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-endif
-
-all-local: $(PREINSTALL_FILES)
-
-PREINSTALL_DIRS =
-PREINSTALL_FILES =
-
-if sh7032
-$(PROJECT_INCLUDE)/sh/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)/sh
- @: > $(PROJECT_INCLUDE)/sh/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/sh/$(dirstamp)
-
-$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)/rtems/score
- @: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-
-$(PROJECT_INCLUDE)/sh/sci.h: include/sci.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/sci.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/sci.h
-
-$(PROJECT_INCLUDE)/sh/sh7_pfc.h: include/sh7_pfc.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/sh7_pfc.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/sh7_pfc.h
-
-$(PROJECT_INCLUDE)/sh/sh7_sci.h: include/sh7_sci.h $(PROJECT_INCLUDE)/sh/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sh/sh7_sci.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sh/sh7_sci.h
-
-$(PROJECT_INCLUDE)/rtems/score/ispsh7032.h: include/ispsh7032.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/ispsh7032.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ispsh7032.h
-
-$(PROJECT_INCLUDE)/rtems/score/iosh7032.h: include/iosh7032.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/iosh7032.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/iosh7032.h
-endif
-
-CLEANFILES += $(PREINSTALL_FILES)
-DISTCLEANFILES = $(PREINSTALL_DIRS)
-
-include $(top_srcdir)/../../../automake/local.am