summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-14 17:07:54 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-14 17:07:54 +0000
commitac8154305172ebcb347f5563dd3ce17d95b4736b (patch)
tree6f24392d14911a8911b287a8b478016c40cb3a26 /c/src/lib/libcpu/sh/configure.in
parentMoved PowerPC cache management code to libcpu. Also compiled (diff)
downloadrtems-ac8154305172ebcb347f5563dd3ce17d95b4736b.tar.bz2
Patch rtems-rc-20000614-sh.tar.gz from Ralf Corsepius
<corsepiu@faw.uni-ulm.de> that migrates the SH port to multilib'ing. This patch involved moving a number of files in the CVS repository, adding new files, and deleting files from their previous location. Ralf gave good instructions (not repeated here) and here are his notes: Note 1: In this version, I did not change the installation points of the headers which are moved inside of the source-tree. This is a temporary hack for not breaking compatibility with 4.5 based BSPs, but will probably not last once having real multilibs (We would have include file conflicts when several BSPs/CPU_MODELS share a common installation prefix). Note 2: I hope not to have broken too much, but I would not be astonished if something goes wrong. Note 3: There are more patches to come :)
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/configure.in23
1 files changed, 6 insertions, 17 deletions
diff --git a/c/src/lib/libcpu/sh/configure.in b/c/src/lib/libcpu/sh/configure.in
index fbf6fbca9e..664b64f105 100644
--- a/c/src/lib/libcpu/sh/configure.in
+++ b/c/src/lib/libcpu/sh/configure.in
@@ -20,25 +20,14 @@ RTEMS_CANONICAL_HOST
RTEMS_PROJECT_ROOT
-RTEMS_PROG_CC_FOR_TARGET
-RTEMS_CANONICALIZE_TOOLS
-
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+if test -d ${srcdir}/$RTEMS_CPU_MODEL; then
+RTEMS_CPU_MODEL_SUBDIR="$RTEMS_CPU_MODEL"
+fi
+AC_CONFIG_SUBDIRS($RTEMS_CPU_MODEL_SUBDIR)
+
# Explicitly list all Makefiles here
AC_OUTPUT(
-Makefile
-sh7032/Makefile
-sh7032/null/Makefile
-sh7032/clock/Makefile
-sh7032/delay/Makefile
-sh7032/include/Makefile
-sh7032/timer/Makefile
-sh7032/sci/Makefile
-sh7045/Makefile
-sh7045/clock/Makefile
-sh7045/include/Makefile
-sh7045/null/Makefile
-sh7045/sci/Makefile
-sh7045/timer/Makefile)
+Makefile)