summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-12-08 13:37:19 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-12-08 13:44:17 +0100
commitf2969b5392e131528ac76b3d3ca877faf3535e34 (patch)
treec0cf77eec5653bea2478ba994f77309d5b7050f3 /c/src/lib/libcpu/sh/Makefile.am
parentbsp/gensh2: Move libcpu files to BSP (diff)
downloadrtems-f2969b5392e131528ac76b3d3ca877faf3535e34.tar.bz2
bsp/gensh4: Move libcpu files to BSP
Update #3254.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/Makefile.am38
1 files changed, 0 insertions, 38 deletions
diff --git a/c/src/lib/libcpu/sh/Makefile.am b/c/src/lib/libcpu/sh/Makefile.am
index 0566cace11..c39db6ea53 100644
--- a/c/src/lib/libcpu/sh/Makefile.am
+++ b/c/src/lib/libcpu/sh/Makefile.am
@@ -9,43 +9,5 @@ cache_rel_SOURCES = ../shared/src/cache_manager.c
cache_rel_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/cache
cache_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-if sh7750
-# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
-# file name conflicts
-include_shdir = $(includedir)/sh
-include_rtems_scoredir = $(includedir)/rtems/score
-
-include_sh_HEADERS = sh7750/include/sh/sh4uart.h
-include_rtems_score_HEADERS = sh7750/include/rtems/score/sh7750_regs.h
-include_rtems_score_HEADERS += sh7750/include/rtems/score/ipl.h
-include_rtems_score_HEADERS += sh7750/include/rtems/score/iosh7750.h
-include_rtems_score_HEADERS += sh7750/include/rtems/score/ispsh7750.h
-include_rtems_score_HEADERS += sh7750/include/rtems/score/sh4_regs.h
-
-## sh7750/clock
-noinst_PROGRAMS += sh7750/clock.rel
-sh7750_clock_rel_SOURCES = sh7750/clock/ckinit.c
-sh7750_clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7750_clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## sh7750/sci
-noinst_PROGRAMS += sh7750/sci.rel
-sh7750_sci_rel_SOURCES = sh7750/sci/sh4uart.c
-sh7750_sci_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7750_sci_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## sh7750/score
-noinst_PROGRAMS += sh7750/score.rel
-sh7750_score_rel_SOURCES = sh7750/score/cpu_asm.c sh7750/score/ispsh7750.c
-sh7750_score_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7750_score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## sh7750/timer
-noinst_PROGRAMS += sh7750/timer.rel
-sh7750_timer_rel_SOURCES = sh7750/timer/timer.c
-sh7750_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7750_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-endif
-
include $(srcdir)/preinstall.am
include $(top_srcdir)/../../../automake/local.am