summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-25 19:32:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-25 19:32:15 +0000
commitbe7ca346fd7771e8fb7483d86877eb480b1a0c69 (patch)
tree4dd5720611eec83dfac8abc2b3433ecbb57bcf1b /c/src/lib/libcpu/sh/Makefile.am
parent2008-09-25 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-be7ca346fd7771e8fb7483d86877eb480b1a0c69.tar.bz2
2008-09-25 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, sh7032/score/cpu_asm.c, sh7045/score/cpu_asm.c, sh7750/score/cpu_asm.c: Move duplicated context switch code to score/cpu and provide an interrupt handling stub for the GDB SuperH simulator since it does not support interrupts or devices. This has been used to run tests on the simulator BSP as SH1, SH2, and SH4. * shgdb/score/cpu_asm.c, shgdb/score/ispshgdb.c: New files.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/sh/Makefile.am b/c/src/lib/libcpu/sh/Makefile.am
index 801366f4c3..a768c0652f 100644
--- a/c/src/lib/libcpu/sh/Makefile.am
+++ b/c/src/lib/libcpu/sh/Makefile.am
@@ -119,5 +119,13 @@ sh7750_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
sh7750_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
+if shgdb
+## sh7045/score
+noinst_PROGRAMS += shgdb/score.rel
+shgdb_score_rel_SOURCES = shgdb/score/cpu_asm.c shgdb/score/ispshgdb.c
+shgdb_score_rel_CPPFLAGS = $(AM_CPPFLAGS)
+shgdb_score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+endif
+
include $(srcdir)/preinstall.am
include $(top_srcdir)/../../../automake/local.am