summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-12-08 13:23:41 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-12-08 13:23:41 +0100
commitb850e7fb76d224f576de6aff2dfa65d5912e9f3f (patch)
tree023288d9741dd8be21fe07d7d5b27980ad2dca90 /c/src/lib/libcpu/sh/Makefile.am
parentbsp/shsim: Move libcpu files to BSP (diff)
downloadrtems-b850e7fb76d224f576de6aff2dfa65d5912e9f3f.tar.bz2
bsp/gensh1: Move libcpu files to BSP
Update #3254.
Diffstat (limited to 'c/src/lib/libcpu/sh/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/Makefile.am43
1 files changed, 0 insertions, 43 deletions
diff --git a/c/src/lib/libcpu/sh/Makefile.am b/c/src/lib/libcpu/sh/Makefile.am
index 6e1576294b..3422fd7032 100644
--- a/c/src/lib/libcpu/sh/Makefile.am
+++ b/c/src/lib/libcpu/sh/Makefile.am
@@ -9,49 +9,6 @@ cache_rel_SOURCES = ../shared/src/cache_manager.c
cache_rel_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/cache
cache_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-if sh7032
-# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
-# file name conflicts
-include_shdir = $(includedir)/sh
-include_rtems_scoredir = $(includedir)/rtems/score
-
-include_sh_HEADERS = sh7032/include/sci.h
-include_sh_HEADERS += sh7032/include/sh7_pfc.h
-include_sh_HEADERS += sh7032/include/sh7_sci.h
-include_rtems_score_HEADERS = sh7032/include/ispsh7032.h
-include_rtems_score_HEADERS += sh7032/include/iosh7032.h
-
-## sh7032/clock
-noinst_PROGRAMS += sh7032/clock.rel
-sh7032_clock_rel_SOURCES = sh7032/clock/ckinit.c
-sh7032_clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7032_clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## sh7032/delay
-noinst_PROGRAMS += sh7032/delay.rel
-sh7032_delay_rel_SOURCES = sh7032/delay/delay.c
-sh7032_delay_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7032_delay_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## sh7032/sci
-noinst_PROGRAMS += sh7032/sci.rel
-sh7032_sci_rel_SOURCES = sh7032/sci/sci.c
-sh7032_sci_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7032_sci_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## sh7032/score
-noinst_PROGRAMS += sh7032/score.rel
-sh7032_score_rel_SOURCES = sh7032/score/cpu_asm.c sh7032/score/ispsh7032.c
-sh7032_score_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7032_score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-### sh7032/timer
-noinst_PROGRAMS += sh7032/timer.rel
-sh7032_timer_rel_SOURCES = sh7032/timer/timer.c
-sh7032_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7032_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-endif
-
if sh7045
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts