summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-12-08 13:31:12 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-12-08 13:31:12 +0100
commit533e2c0af6dad96de5c8123206adebea2fbb06d2 (patch)
treefdff3fdd8c09aac5b809d672399c634062871662 /c/src/lib/libcpu/sh/Makefile.am
parentbsp/gensh1: Move libcpu files to BSP (diff)
downloadrtems-533e2c0af6dad96de5c8123206adebea2fbb06d2.tar.bz2
bsp/gensh2: Move libcpu files to BSP
Update #3254.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/sh/Makefile.am39
1 files changed, 0 insertions, 39 deletions
diff --git a/c/src/lib/libcpu/sh/Makefile.am b/c/src/lib/libcpu/sh/Makefile.am
index 3422fd7032..0566cace11 100644
--- a/c/src/lib/libcpu/sh/Makefile.am
+++ b/c/src/lib/libcpu/sh/Makefile.am
@@ -9,45 +9,6 @@ cache_rel_SOURCES = ../shared/src/cache_manager.c
cache_rel_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/cache
cache_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-if sh7045
-# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
-# file name conflicts
-include_shdir = $(includedir)/sh
-include_rtems_scoredir = $(includedir)/rtems/score
-
-include_sh_HEADERS = sh7045/include/io_types.h
-include_sh_HEADERS += sh7045/include/sci.h
-include_sh_HEADERS += sh7045/include/sh7_pfc.h
-include_sh_HEADERS += sh7045/include/sh7_sci.h
-include_sh_HEADERS += sh7045/include/sci_termios.h
-include_rtems_score_HEADERS = sh7045/include/ispsh7045.h
-include_rtems_score_HEADERS += sh7045/include/iosh7045.h
-
-## sh7045/clock
-noinst_PROGRAMS += sh7045/clock.rel
-sh7045_clock_rel_SOURCES = sh7045/clock/ckinit.c
-sh7045_clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7045_clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## sh7045/sci
-noinst_PROGRAMS += sh7045/sci.rel
-sh7045_sci_rel_SOURCES = sh7045/sci/sci.c sh7045/sci/sci_termios.c
-sh7045_sci_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7045_sci_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## sh7045/score
-noinst_PROGRAMS += sh7045/score.rel
-sh7045_score_rel_SOURCES = sh7045/score/cpu_asm.c sh7045/score/ispsh7045.c
-sh7045_score_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7045_score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-## sh7045/timer
-noinst_PROGRAMS += sh7045/timer.rel
-sh7045_timer_rel_SOURCES = sh7045/timer/timer.c
-sh7045_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
-sh7045_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-endif
-
if sh7750
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts