summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/sh/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-05-11 07:57:29 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-05-11 07:57:29 +0000
commit305d6bfddb5459288881307315aa5456f140c828 (patch)
tree6bf5e7481d34ad68cc39903a5246af3081494839 /c/src/lib/libcpu/sh/Makefile.am
parentRemove sh7750/Makefile. (diff)
downloadrtems-305d6bfddb5459288881307315aa5456f140c828.tar.bz2
Merge-in sh7750/Makefile.am.
Diffstat (limited to 'c/src/lib/libcpu/sh/Makefile.am')
-rw-r--r--c/src/lib/libcpu/sh/Makefile.am41
1 files changed, 37 insertions, 4 deletions
diff --git a/c/src/lib/libcpu/sh/Makefile.am b/c/src/lib/libcpu/sh/Makefile.am
index 165187ff52..09bb5cc686 100644
--- a/c/src/lib/libcpu/sh/Makefile.am
+++ b/c/src/lib/libcpu/sh/Makefile.am
@@ -10,8 +10,6 @@ CLEANFILES =
DISTCLEANFILES =
noinst_PROGRAMS =
-SUBDIRS = sh7750
-
if sh7032
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
@@ -80,14 +78,49 @@ sh7045_score_rel_SOURCES = sh7045/score/cpu_asm.c sh7045/score/ispsh7045.c
sh7045_score_rel_CPPFLAGS = $(AM_CPPFLAGS)
sh7045_score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-### sh7045/timer
+## sh7045/timer
noinst_PROGRAMS += sh7045/timer.rel
sh7045_timer_rel_SOURCES = sh7045/timer/timer.c
sh7045_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
sh7045_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
+if sh7750
+# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
+# file name conflicts
+include_shdir = $(includedir)/sh
+include_rtems_scoredir = $(includedir)/rtems/score
+
+include_sh_HEADERS = sh7750/include/sh/sh4uart.h
+include_rtems_score_HEADERS = sh7750/include/rtems/score/sh7750_regs.h \
+ sh7750/include/rtems/score/ipl.h sh7750/include/rtems/score/iosh7750.h \
+ sh7750/include/rtems/score/ispsh7750.h sh7750/include/rtems/score/sh4_regs.h
+
+## sh7750/clock
+noinst_PROGRAMS += sh7750/clock.rel
+sh7750_clock_rel_SOURCES = sh7750/clock/ckinit.c
+sh7750_clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
+sh7750_clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+## sh7750/sci
+noinst_PROGRAMS += sh7750/sci.rel
+sh7750_sci_rel_SOURCES = sh7750/sci/sh4uart.c
+sh7750_sci_rel_CPPFLAGS = $(AM_CPPFLAGS)
+sh7750_sci_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+## sh7750/score
+noinst_PROGRAMS += sh7750/score.rel
+sh7750_score_rel_SOURCES = sh7750/score/cpu_asm.c sh7750/score/ispsh7750.c
+sh7750_score_rel_CPPFLAGS = $(AM_CPPFLAGS)
+sh7750_score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+## sh7750/timer
+noinst_PROGRAMS += sh7750/timer.rel
+sh7750_timer_rel_SOURCES = sh7750/timer/timer.c
+sh7750_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
+sh7750_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+endif
+
include $(srcdir)/preinstall.am
-include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am