summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/wrapup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:50:45 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:50:45 +0000
commitbc2f04f8a8192e148ca9832c49c1c73a445f4310 (patch)
tree12dc7cb8f8eb044a52ba59ee466823066e215513 /c/src/lib/libcpu/powerpc/wrapup/Makefile.am
parentPatch rtems-rc-20000104-11.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-bc2f04f8a8192e148ca9832c49c1c73a445f4310.tar.bz2
Patch rtems-rc-20000104-13.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which does the following: * some cleanups, fixes, addtions to the libbsp automake transition patches * The missing Automake transistion patches all libcpu/<cpu>/<variant>/* previously not yet been converted to automake (libcpu/powerpc, libcpu/hppa1.1, libcpu/mips64orion, libcpu/sparc) => With this patch, libcpu/*/* is under full automake control. NOTES: * This patch is tested by building for random set of bsps affected by this patch, but not tested for all BSPs. * The parts of this patch related to libcpu/powerpc fix many small bugs inside of those Makefiles. * Have a look into libcpu/powerpc/mpc6xx/, which is in rather bad shape, IMO. Obviously most subdirectories seem to be build but are not included into libcpu.a by wrapup/Makefile. Addtionally, no actual BSP uses this cpu-variant subdirectory. Furthermore libcpu/powerpc/mpc6xx has a different directory layout than all other powerpc/<variant>/ directories. Joel's note: I agree but the issue is that there is a conflict between including timer or clock in libcpu/XXX/wrapup/Makefile.* and letting a BSP specifically decide to pick it up. There is no clear solution to this at the moment.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/powerpc/wrapup/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/wrapup/Makefile.am b/c/src/lib/libcpu/powerpc/wrapup/Makefile.am
new file mode 100644
index 0000000000..609b64bbfb
--- /dev/null
+++ b/c/src/lib/libcpu/powerpc/wrapup/Makefile.am
@@ -0,0 +1,36 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+GENERIC_FILES = shared
+
+# Use two variables so that I can make two ar command.
+# So far FAMILY_OBJS is empty and ar dislike it...
+CPU_SPECIFIC_OBJS = $(wildcard ../$(RTEMS_CPU_MODEL)/*/$(ARCH)/*.o)
+FAMILY_OBJS = $(wildcard ../shared/$(ARCH)/*.o ../shared/*/$(ARCH)/*.o \
+ ../mpc6xx/*/$(ARCH)/*.o)
+
+LIB = $(ARCH)/libcpu.a
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+libcpu_a_OBJECTS = $(CPU_SPECIFIC_OBJS) $(FAMILY_OBJS)
+
+$(LIB): $(libcpu_a_OBJECTS)
+ ${make-library}
+
+$(PROJECT_RELEASE)/lib/libcpu$(LIB_VARIANT).a: $(LIB)
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/libcpu$(LIB_VARIANT).a
+
+all-local: ${ARCH} $(LIB) $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am