summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc860/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-21 16:20:38 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-21 16:20:38 +0000
commit400c55255d516a27fd25de899826286458f559dc (patch)
treef6c262848a647ba5004d0297999500b81161532e /c/src/lib/libcpu/powerpc/mpc860/include/Makefile.am
parentPatch rtems-rc-19991203-10.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-400c55255d516a27fd25de899826286458f559dc.tar.bz2
Removing Makefile.in and adding Makefile.am. These were missed in conversion
to automake by Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc860/include/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc860/include/Makefile.am b/c/src/lib/libcpu/powerpc/mpc860/include/Makefile.am
new file mode 100644
index 0000000000..4bd4d6d7b5
--- /dev/null
+++ b/c/src/lib/libcpu/powerpc/mpc860/include/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = mpc860.h
+MPC860_H_FILES = console.h
+
+noinst_HEADERS = $(H_FILES) $(MPC860_H_FILES)
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE)/mpc860 \
+$(H_FILES:%.h=$(PROJECT_INCLUDE)/%.h) \
+$(MPC860_H_FILES:%.h=$(PROJECT_INCLUDE)/mpc860/%.h)
+
+$(PROJECT_INCLUDE)/mpc860:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/mpc860/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../automake/local.am