summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc6xx/timer/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libcpu/powerpc/mpc6xx/timer/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc6xx/timer/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc6xx/timer/Makefile.am b/c/src/lib/libcpu/powerpc/mpc6xx/timer/Makefile.am
index 39f0c9f3b6..a8bfed1b4a 100644
--- a/c/src/lib/libcpu/powerpc/mpc6xx/timer/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/mpc6xx/timer/Makefile.am
@@ -4,12 +4,11 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGM = ${ARCH}/timer.rel
+PGM = $(ARCH)/timer.rel
-## C sources
C_FILES = timer.c
-timer_rel_OBJECTS = $(C_FILES:%.c=${ARCH}/%.o)
+timer_rel_OBJECTS = $(C_FILES:%.c=$(ARCH)/%.o)
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../../../../../automake/lib.am
@@ -23,8 +22,10 @@ AM_CFLAGS = $(CFLAGS_OS_V)
$(PGM): $(timer_rel_OBJECTS)
$(make-rel)
-all-local: ${ARCH} $(PGM)
+all-local: $(ARCH) $(timer_rel_OBJECTS) $(PGM)
-EXTRA_DIST = $(C_FILES)
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = timer.c
include $(top_srcdir)/../../../../../automake/local.am